Ubuntu 18 ltib fails

cancel
Showing results for 
Search instead for 
Did you mean: 

Ubuntu 18 ltib fails

67 Views
mariusoctavian
Contributor I


The ltib for imx6 fails with following error on  Ubuntu 18.04 machine.


+ make
Making all in gst-libs
Making all in gst
Making all in interfaces
Making all in signalprocessor
Making all in video
Making all in gst
Making all in aiff
Making all in asfmux
Making all in audioparsers
Making all in debugutils
Making all in rawparse
Making all in selector
Making all in sys
Making all in ext
Making all in alsaspdif
Making all in sdl
LINK libgstsdl.la
/opt/gcc-arm-9.2-2019.12-x86_64-arm-none-linux-gnueabihf/bin/../lib/gcc/arm-none-linux-gnueabihf/9.2.1/../../../../arm-none-linux-gnueabihf/bin/ld: cannot find -lSDL
collect2: error: ld returned 1 exit status
make[3]: *** [Makefile:585: libgstsdl.la] Error 1
make[2]: *** [Makefile:821: all-recursive] Error 1
make[1]: *** [Makefile:644: all-recursive] Error 1
make: *** [Makefile:569: all] Error 2
error: Bad exit status from /sdaone/imx6ltib/tmp/rpm-tmp.41090 (%build)


RPM build errors:
Bad exit status from /sdaone/imx6ltib/tmp/rpm-tmp.41090 (%build)
Build time for gst-plugins-bad: 11 seconds

Failed building gst-plugins-bad


f_buildrpms() returned an error, exiting
traceback:
main:572


Started: Tue Mar 16 21:45:19 2021
Ended: Tue Mar 16 21:45:31 2021
Elapsed: 12 seconds

These packages failed to build:
gst-plugins-bad

Build Failed


This Ubuntu was installed long ago and I have other IDE's and tools installed.

Though the same build procedure works fine on a clean Ubuntu 18 distro.

Any idea where to look or what package might interfere with ltib.
I already force & reinstalled the following


 

build-essential
dos2unix
intltool
libfile-slurp-perl
libglib2.0-dev
libncurses5-dev
libppi-perl
libssl-dev
python
rpm
unzip
zip
zlib1g-dev
gcc-multilib
libssl-dev:i386
zlib1g-dev:i386

 

 

 

 

0 Kudos
1 Reply

28 Views
Tong
Contributor I

You can remove or rename /usr/bin/sdl-config file to work around this build error.

0 Kudos