Problem With Quick Start r2.7

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem With Quick Start r2.7

158 Views
Contributor II

hi every one

i use Freescale Codewarrior IDE version 8 (but in about menu ide version is 5.9) for mc56f8006.

i have problem with  NXP Stationery New Project Wizard.

i cant add this to codewarrior new project window.

i install Quick Start r2.7

can anyone help.

thanks

Labels (1)
6 Replies

37 Views
NXP TechSupport
NXP TechSupport

Hi, Milad,

I suggest you use CodeWarrior for MCU version11.x to develop code for MC56F8006. After you install the CW for mcu ver11.x, you can click File->New->BareBoard project, then input project name and select the processor, it is okay.

Hope it can help you

BR

XiangJun Rong

pastedImage_1.png

37 Views
Contributor II

hi sir

thanks for your replay

no , i use codewarrior for dsc version 8.3 , the full name :

"FreeScale CodeWarrior for 56800E Digital Signal Controllers v8.3.exe"

and after i install "DSC56800EX-QUICK-START" i can not see :

"DSP56800E Quick Start r2.7 Stationary"

in my new project window.

also after installing "DSC56800EX-QUICK-START" , the readme file say that you must go to project properties and do some settings but i cannot find "project properties" in codewarrior.

 

0 Kudos

37 Views
NXP TechSupport
NXP TechSupport

Hi, Milad,

If you use the classic codewarrior for dsc version 8.3, I suppose that you can use Processor Expert or write peripheral register directly to develop code.

But the  "DSC56800EX-QUICK-START" is a plug-in component only for CodeWarrior for MCU version11.x, I suppose it can not be installed on  the classic codewarrior for dsc version 8.3.

BR

XiangJun Rong

37 Views
Contributor II

i installed last version of codewarrior and my problem solved.

but in quick start tool version r2.7 , do not support mc56f8006 and i must instal quick satrt version 2.5

but i can not find it.

can you put a link of quick start tool version 2.5 ??

i attach a picture of supported device in r2.7 version.

thanks 

0 Kudos

37 Views
NXP TechSupport
NXP TechSupport

Hi, Milad,

Pls refer to the following section, you have to install the "DSC56800EX-QUICK-START" to the CodeWarrior for Microcontrollers CodeWarrior Development Studio V11.1 (or later)  rather than the Codewarrior for DSP56800E version 8.3(classic). The Codewarrior for DSP56800E version 8.3(classic) is very old.

BR

XiangJun Rong

From the UM of "DSC56800EX-QUICK-START:

"

1.2.1 CodeWarrior for Microcontrollers CodeWarrior Development Studio V11.1 (or later) is a complete Integrated Development Environment (IDE) that provides a highly visual and automated framework to accelerate development of the most complex embedded applications. CodeWarrior for Microcontrollers integrates the development tools for the ColdFire®, ColdFire+, DSC, Kinetis, Qorivva, PX, RS08, S08, and S12Z architectures into a single product based on the Eclipse open development platform. Eclipse offers an excellent framework for building software development environments and is a standard framework used by many embedded software vendors. As previously mentioned, DSC56800EX_Quick_Start tool is designed for and can be integrated with CodeWarrior for Microcontrollers development tool. With CodeWarrior for Microcontrollers tool, users can build applications and integrate other software included as part of the DSC56800EX_Quick_Start release. Once the software is built, CodeWarrior tools allows users to download executable images into the target platform and run or debug the downloaded code. To install CodeWarrior for Microcontrollers V11.1, it is recommended to use the installation guide attached to the actual version of CodeWarrior for Microcontrollers, if available.

"

37 Views
Contributor II

Thanks Dear XiangJun

i do that.

0 Kudos