How do I get my CodeWarrior USB TAP to communicate

cancel
Showing results for 
Search instead for 
Did you mean: 

How do I get my CodeWarrior USB TAP to communicate

369 Views
Contributor I

The CodeWarrior is new to me.

I have a new T2081RDB unit, which boots up with factory installed images.
I have removed the cover and connected a CodeWarrior USB TAP to the T2080_COP 16-pin connector.
The USB TAP is hosted on a PC running VMware Workstation 12 Pro, loaded with Ubuntu 14.04.3.
On this VMware Workstation I have loaded CodeWarrior Development Studio for Power Architecture v10.5.1 - Linux.tar
by un-tar'ing and running (as root) ./setuplinux -c

My goal is to simply read the T2080 SCRATCHRW2 register.

Using the serially connected console, I inturrupted the boot processes, receiving a u-boot prompt.
I connect the TAP to the host PC.
The LED's on the TAP: TX/RX blinks red 1Hz for a few seconds, then blinks red at 5Hz for about a second, then green at 1Hz continually.
RUN/PAUSE, over the same time period, one initial red blink, off until the TX/RX blinks green, one green blink then remains off.

Looking at ccs/drivers/readme files and searching for help on-line it appears that the USB TAP drivers may need to be installed manually.
As root, I copied 00-usbtab.rules to /etc/udev/rules.d/. (I also tried /lib/udev/rules.d/.)
I copied usbtap to /etc/udev/.
I executed the commnad: udevcontrol reload_rules.
I also tried re-booting linux.
Nothing seems to change the TAP LEDs from TX/RX blinking green 1Hz, RUN/PAUSE off.

I start up the CodeWarrior Development Studio IDE (CodeWarrior_PA_10.5.1/eclipse/cwide)
File>New>CodeWarrior Bareboard Project Wizard
Name: etb2
Processor: T2080
Project Output: Application
Board: T2080RDB-PCIe
Launch: Connect (Default)
Connection Type: CodeWarrior TAP (Over USB)
Language: C
Build Tools Architecture: 32 bit
Toolchain: GCC AEABI e6500
FloatingPoint: Hardware
Processing Model: AMP (One project per core)
Core index: Core 0

Attempt to run this application under debug by selecting: etb2-core00_RAM_T2080_Connect[CodeWarrior]
After the build completes I get a pop-up
Problem Occurred
Launching etb2-core00_RAM_T2080_Connect has encountered a problem.
Would you like to export diagnostic information and send it to Freescale?
Error launching etb2-core00_RAM_T2080_Connect
Details>> CCSProtocolPlugin: Could not connect to the probe (or other debug link)
[CCS last error: CC config string is invalid]
Export Diagnostics selected. (201910011218_DiagnosticInfo.zip)

I start up the /opt/Freescale/CodeWarrior_PA_10.5.1/PA/ccs/bin/ccs (CodeWarrior Connection Server command line app.
Interp>Show Last Error:
unknown option "-state"
while executing
"$menu entrycget $1 -state"
Searching through source code and help files, it appears that "-state" option is only for ccs running on windows?
On the ccs command-line I enter: findcc utaps
USB TAP Serial Numbers:
10261782
(which does match my TAP)

Tags (1)
0 Kudos
5 Replies

89 Views
NXP TechSupport
NXP TechSupport

CodeWarrior USB TAP can be used under CodeWarrior 8.8 or CodeWarrior MGT 9.2.

CodeWarrior 10.5 does not support CodeWarrior USB TAP.

Have a great day,
Pavel Chubakov

0 Kudos

89 Views
NXP TechSupport
NXP TechSupport

NXP recommends using CodeWarrior TAP for CodeWarrior 10.5. See the following page:

https://www.nxp.com/design/software/development-software/codewarrior-development-tools/run-control-d...

 

See the CodeWarrior TAP Probe User Guide:

https://www.nxp.com/docs/en/user-guide/CWTAPUG.pdf

 

Use CodeWarrior TAP on your board.

Have a great day,
Pavel Chubakov

0 Kudos

89 Views
Contributor I

Thank you Pavel,

The documentation you sent to me works for the “CodeWarrior TAP” and it is now working.

That is good enough for my current needs. This Case can close.

I still cannot get the other TAP to work, called “CodeWarrior USB TAP”. It does not have the Host Ethernet port. Only the USB port.

It connects to the target in the same way. If you have documentation for it, I would be happy to see it. If not, I need to move on.

Eric Burgoyne

0 Kudos

89 Views
NXP TechSupport
NXP TechSupport

I have tested CodeWarrior 10.5.1 using Ubuntu 14.04.5-desktop-i386 under VMware.

CodeWarrior TAP driver was installed automatically.

Test connection to your CodeWarrior TAP using the following commands in CCS window:

log v

source IDcode.tcl

Have a great day,
Pavel Chubakov

 

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

89 Views
Contributor I

Hello Pavel,

I have two different CodeWarrior TAP’s.

One is labeled “CodeWarrior USB TAP”, on the back it has 900-75115, REV F, 10261782, and COP.

It has a USB connector for the Host interface and no power cable.

This is the one that I was trying to get to work in this case number.

The Second TAP is labeled “CodeWarrior TAP”, on the back it has 900-76173, REV E, 15191862, and a ETHERNET MAC address.

It has a RJ45 Ethernet connector for the Host interface and a port for connecting external power.

This one I was not using because the IP address had been hard coded internally and I did not know what it was.

On the CodeWarrior Development Studio Eclipse CWIDE app, when I choose a New CodeWarrior Bareboard Project Wizard,

The “Debug Target Settings” page asks for Connection Type with the choices:

“CodeWarrior TAP (over USB)”, “CodeWarrior TAP (over Ethernet)”, “Ethernet TAP”,

“USB TAP”, “Gigabit TAP”, and “Gigabit TAP + Trace (JTAG over JTAG cable)”.

The obvious choice is “CodeWarrior TAP (over USB)”.

This was my configuration that would not illuminate the Run/Pause LED on the CodeWarrior USB TAP,

and the reason that I wrote up this issue.

If I select this new bareboard project under Debug Configurations and Edit Target Settings,

there is a Hardware or Simulator Connection page that opens.

One entry is Connection Type, with the choices “CodeWarrior TAP”, “Ethernet TAP”, “USB TAP”, “Gigabit TAP”, and “Gigabit TAP + Trace”.

And it is set to “CodeWarrior TAP” by default. “CodeWarrior TAP (over USB)” was not one of the choices.

If I change the Connection type to “USB TAP” then the Run/Pause LED on the TAP turns Red, but I still seem to have no control to Run/Pause the execution.

I manually installed the 00-usbtap.rules under /etc/udev/rules.d. That did not do the job.

I just don’t know what I need to install to get this CodeWarrior USB TAP to communicate.

With no other ideas on the USB TAP, I figured out the IP address for the CodeWarrior TAP (over Ethernet).

This one is working, and the driver installed automatically, as you stated. I am now able to proceed with my work,

But I would still like to know how the get the CW USB TAP to work.

0 Kudos