Debugging U-Boot on ARMv8 with Eclipse/CodeWarrior TAP

cancel
Showing results for 
Search instead for 
Did you mean: 

Debugging U-Boot on ARMv8 with Eclipse/CodeWarrior TAP

892 Views
stacym
Contributor I

Hi all,

I am working currently with the LS1043A-RDB board.  I'd like to be prepared for custom hardware arriving shortly.  I've followed the instructions in the Document "Use CodeWarrior for ARMv8 to Debug U-boot and Linux Kernel and Bring up Bare Boards" written by Yiping Wang and also tried "ANxxxx Building U-Boot in CodeWarrior ARMv8"  I am able to get pretty far, build U-Boot, burn U-Boot into NOR flash, verify image in flash.  I created build and debug configurations per instructions in documents, trying both the attach method and the debug method.  Both methods fail in the same way, the debug phase aborts with a message:  Launching u-boot debug has encountered a problem:

Error in final launch sequence

    Failed to execute MI command:

    -break-insert -t _start

Error message from debugger back end:

Function "_start" not defined.

Another dialog box also appears:  One or more sections of the remote executable does not match the loaded

Section .data, range 0x60100000 - 0x601a1c4b: MIS-MATCHED!

I'm using CW Version 11.2.3 Build 170322

Anyone do anything similar with better luck?

Thanks,

Stacy

0 Kudos
3 Replies

369 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Stacy,

Please check whether u-boot programmed to NOR flash can be set up successfully.

Did you import the elf file "u-boot" into CodeWarrior to create a debug project?

Please make sure u-boot elf file import into CodeWarrior is from the same build with the binary file programmed to NOR flash.

Please follow the section "Debug u-boot with CodeWarrior for ARMv8" in the step by step document Use CodeWarrior for ARMv8 to Debug U-boot and Linux Kernel and Bring up Bare Boards to debug u-boot with the Attach method, I have verified it previously.

If your problem remains, please send your CodeWarrior debug project to me to do more investigation.


Have a great day,
TIC

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

369 Views
brettstahlman
Contributor III

Yiping,

I'm using flex-builder to build u-boot, and this produces a .bin but no .elf binary. How to I build a debuggable ELF using flex-builder? There don't appear to be any documented options for this...

Thanks,

Brett S.

0 Kudos

369 Views
addiyi
NXP Employee
NXP Employee

Check chapter 8.1 from \Freescale\CW4NET_v2017.03\CW_ARMv8\ARMv8\Help\PDF\ARMv8_Targeting_Manual.pdf

Adrian

0 Kudos