CW barebone project on LS1012-FRDM

cancel
Showing results for 
Search instead for 
Did you mean: 

CW barebone project on LS1012-FRDM

861 Views
robertsedevcic
Contributor I

Hello,

I'm evaluating CW Studio for QorlQ with LS1012A-FRDM board. I followed the instructions to create a barebone C project. My debug probe is on-board CMSIS-DAP. Progress window shows the following status for at least 5 min (green LED is blinking) before it finally displays "No operation to display at this time". 

pastedImage_1.png

Debug window shows the following status:

pastedImage_2.png

The problem is that no debug operation is available:

pastedImage_3.png

When I manipulate breakpoints, gdb console returns: "Program received signal SIGINT, Interrupt"

Please help what might be the problem. Thanks.

Robert

0 Kudos
7 Replies

318 Views
addiyi
NXP Employee
NXP Employee

Did you use Connect or Inspect option? The difference is that Inspect just attach to the board (seems to be your case) while Connect will execute the initialization.

Adrian 

0 Kudos

318 Views
robertsedevcic
Contributor I

I managed to restore K20 firmware and connection seems OK now:

pastedImage_1.png

But when I run a debug session, I'm still unable to debug since:

- launching is stalled at 92% 

pastedImage_2.png

- D1 led is blinking fast

Finally launching ends and this is what I get:

-debug perspective

pastedImage_2.png

-gdb output after setting BPs

 pastedImage_1.png

I'm still unable to execute simple debug operations as step etc.

0 Kudos

318 Views
robertsedevcic
Contributor I

It seems that evaluation license will expire before I get any usable answer.

Is there any additional info to detect what might be the problem in my case?

0 Kudos

318 Views
addiyi
NXP Employee
NXP Employee

Do you have any run control from that state?

Adrian

0 Kudos

318 Views
robertsedevcic
Contributor I

Launching a project takes several minutes (stalled at 92% most of the time) after a debug session is started. None of the BPs is hit and when I set a new BP I get following message:

Program received signal SIGINT, Interrupt.
0x000000009fd2fa00 in ?? ()

It seems that this is a DDR address.

I would like to know where are these ARMv8 Stationery barebone examples located? Are they downloaded into DDR, because reset loads preloaded Linux again (from QSPI memory)?

This is a control I have after project is launched:

pastedImage_2.png

0 Kudos

320 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please refer to the document to C:\Freescale\CW4NET_v2017.03\CW_ARMv8\ARMv8\Help\Getting_Started_for_CW_ARMv8.pdf to create a bareboard project to do download and debug the sample program in DDR.


Have a great day,
TIC

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

320 Views
robertsedevcic
Contributor I

I run "Diagnose Connection" button and Connect to probe step failed with 'Could not connect to probe cmsisdap'. When I connect USB cable to the J11 connector, D3 blinks once but D1 is always off. After reset switch (SW1) is pressed, then D1 starts blinking.

I guess that K20 firmware is corrupted. How to restore the board into the factory default state?

0 Kudos