processor expert Version 0412 versus 0444 component failure

cancel
Showing results for 
Search instead for 
Did you mean: 

processor expert Version 0412 versus 0444 component failure

231 Views
jaymoskowitz
Contributor I

I reported in a prior post that when I went to compile anything, I was getting an error "Timing setting failed. Not possible to generate code" and Error in the component setting. More details provided by Component Inspector for this component". In researching this further, I found that I was able to compile prior releases of the software in directories that had its own copy of the Project.mcp and Project.pe files. I further found that all the versions that compiled properly had the following line at the start of the Project.pe file: Processor Expert Version 0412. I compared the .pe of the prior releases and they were all the same. But the current software director Proejct.pe file says Processor Expert Version 0444. A comparison to 0412 shows that 0444 has many other definitions in the file. So I saved that directory, made a copy, and replaced the .mcp and .pe files from the prior software version that worked. I was able to successfully compile and link the software changes.

 

So the questions are:

     1) How did I end up with a new .pe file for Version 0444 when nothing changed in the environment.

     2) Why do I get the two error messages when attempting to compile (which it will not allow me to do).

 

At lease I can get back to debugging code instead of debugging Code Warrior.

Labels (1)
0 Kudos
3 Replies

123 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello Jay,

Could you please tell us the overall information to help you .

1) Which IDE ? Which chip ?

2) What about the component ? Do you meaning add  one PE component on previous PE project ?

3) I recommend you tell us the steps how to reproduce your problem .

BR

Alice

0 Kudos

123 Views
jaymoskowitz
Contributor I

Alice - this comment was actually part of a separate thread called

Error: Timing setting failed. It is not possible to generate code.

The answers to your questions are in that posting. That posting was the original problem that was encountered. But since this site is moderated, that posting was not published to the community while I was attempting to find a solution. So the comments here were not able to be added to the original at that time. Now that the original was posted, the comments above were added to it.

The error messages originally produced did not make any sense to me. But investigations found a different Project.pe file in place in the new software release being compiled that did not exist in any of the prior folders with software versions. We maintain each version of the software in its own directory structure. This problem went away when we copied the two files mentioned from the old directory to the new one. But we have no idea why the Project.pe file could even have gotten updated.

Please comment back on the original posting if you can help to shed any insight into what went wrong.

0 Kudos

123 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello Jay,

I check that thread you have introduce the problem clearly, and there will

be my other colleague to help you on that thread .

BR

Alice

0 Kudos