Debugging with hexfile

cancel
Showing results for 
Search instead for 
Did you mean: 

Debugging with hexfile

Jump to solution
427 Views
bob_walker
Contributor III

I have a boot loader that updates the user application via SCI.

The application runs fine when compiled stand alone. However when running with the boot loader, its behavior is erratic.

The boot loader clears all memory, my application uses no static variables, and I'm not using any CW libraries.

After loading the new image into flash, I can see that the code and its interrupts are mapped where they should be.

 

What I'd like to do is to connect to the target via a debug configuration (CONNECT?) that will not disturb the image and

will use the application's symbols for debugging. Is this possible? If so, how?

Labels (1)
0 Kudos
1 Solution
218 Views
trytohelp
NXP Employee
NXP Employee

Hi Bob,

You can configure the debug through the Debug as ¦ Debug configurations ...

For Debug session type instead of Download you can select Attach or connect

In this case when you will launch a debug session, the application is not load on board.

Only connection to the board is done.

pastedImage_0.png

For details please have a look to the post:

      Hot-Sync: Attach, Connect & Download | MCU on Eclipse

the options are changed but descriptions are still valid.


Have a great day,
Pascal Irrle

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
3 Replies
218 Views
trytohelp
NXP Employee
NXP Employee

Hi Bob,

Can you please let me know the tool version you're using and the architecture ?

If I'm right you can load on board the application with bootloader.

The problem is to debug the application loaded on board.

Am I right ?


Have a great day,
Pascal Irrle

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
218 Views
bob_walker
Contributor III

Pascal,

I'm using CW10.6, 9S08SH16. You are correct.

0 Kudos
219 Views
trytohelp
NXP Employee
NXP Employee

Hi Bob,

You can configure the debug through the Debug as ¦ Debug configurations ...

For Debug session type instead of Download you can select Attach or connect

In this case when you will launch a debug session, the application is not load on board.

Only connection to the board is done.

pastedImage_0.png

For details please have a look to the post:

      Hot-Sync: Attach, Connect & Download | MCU on Eclipse

the options are changed but descriptions are still valid.


Have a great day,
Pascal Irrle

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos