Codewarrior 10.5 Update just broke my install

cancel
Showing results for 
Search instead for 
Did you mean: 

Codewarrior 10.5 Update just broke my install

448 Views
yibbidy
Contributor V

I just started up my working CW10.5 and it said that there were updates available.  So I installed them.  I also installed the new Windows updates at the same time.  Now CW won't start up, it crashes out pointing to an error log.

 

I usually use CW10.2 on Linux, but just a week ago I decided to try CW10.5 on Windows.  Hmmmm......

 

I'm wondering if this Java issue came about through the Windows update or the CW update.  Anyway, here is the log:

 

eclipse.buildId=I20070613-1755

java.version=1.6.0_15

java.vendor=Sun Microsystems Inc.

BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en

Command-line arguments:  -os win32 -ws win32 -arch x86

 

!ENTRY org.eclipse.osgi 4 0 2014-01-09 16:04:25.978

!MESSAGE Application error

!STACK 1

java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:

    C:\Freescale\CW MCU v10.5\eclipse\configuration\org.eclipse.osgi\bundles\242\1\.cp\swt-win32-4236.dll: Invalid access to memory location

    no swt-win32 in java.library.path

    Can't load library: C:\Users\shaun\.swt\lib\win32\x86\swt-win32-4236.dll

    Can't load library: C:\Users\shaun\.swt\lib\win32\x86\swt-win32.dll

    C:\Users\shaun\.swt\lib\win32\x86\swt-win32-4236.dll: Invalid access to memory location

 

    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:331)

    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:240)

    at org.eclipse.swt.internal.C.<clinit>(C.java:21)

    at org.eclipse.swt.widgets.Display.<clinit>(Display.java:138)

    at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:653)

    at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)

    at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:154)

    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:96)

    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)

    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)

    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)

    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)

    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

    at java.lang.reflect.Method.invoke(Unknown Source)

    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:630)

    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:585)

    at org.eclipse.equinox.launcher.Main.run(Main.java:1439)

Labels (1)
3 Replies

135 Views
trytohelp
NXP Employee
NXP Employee

Hello James,

Under google I found some information regarding this error message.

Please have a look to:

      Eclipse Community Forums: Newcomers » Hello World SWT - Could not load SWT library

    

I've MCU V10.5 and other version installed on Win 7 32 bit  and Win 7 64 bit OS.

Both versions are running fine.

May be the problem occurs as the updates were done at same time.

Can you try to un-install windows updates ?

      this could may be solved the problem.

Regards

Pascal

135 Views
yibbidy
Contributor V

Hi Pascal,

It's fixed now.  I was able to uninstall only 3 of the 5 updates, and had to reboot between each one, otherwise none of them would uninstall.  CW10.5 started working again.  I was then able to reapply the 3 updates and CW is still working.

Thanks for your help.

Regards,

Shaun

0 Kudos

135 Views
trytohelp
NXP Employee
NXP Employee

Hi Shaun,

Thanks for feedback.

Don't hesitate to contact us.

Regards

Pascal

0 Kudos