FXTH87xx11 Target connection Lost

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

FXTH87xx11 Target connection Lost

890 Views
loganchen
Contributor I

Hi There

I’m debugging FXTH87xx11_Starter_Project_CW10 project downloaded from Freescale website, and found some issue.

( http://www.freescale.com/files/sensors/software_tools/FXTH87xx11_StarterProject_CW10.zip?WT_TYPE=Lab... )

 

I debugged this project using the step over function. The debug window displayed “Target connection Lost” when executed firmware routine. The details show in the following picture. For example, when executed TPMS_READ_VOLTAGE() function, “Target connection Lost” would display.

u8Status  = TPMS_READ_VOLTAGE(gu16UUMA);

The routine could run normally before the firmware routine.

Pls help me work it well.

 

codewarrior version:10.6.4

Debuggerr: U-MULTLINK-FX

 

34318_34318.JPG捕获2.JPG

Labels (1)
3 Replies

691 Views
sakthivelkuland
Contributor III

Hi logan,

I'm also facing the same problems with the target FXTH870911 could your post some more details about the reason which you found"executed the Erase flash command, codewarrior would erase the address of Firmware Jump Table (0xE000-0xE03F)."

if i understood correctly , During Flashing to Target shouldn't used the "Erase Whole Device" we need to select the Erase and program option.

option Erase whole Device will may erase pre-loaded  Firmware.

pastedImage_2.png

Please let me know if my understanding is correct?

Thanks,

Sakthivel K

0 Kudos

691 Views
Joshevelle
Senior Contributor I

Hello Logan,

Thanks for using our community.

Unfortunately you cannot debug the firmware that is preloaded into the FXTH87xx11. The read voltage function is part of the preloaded firmware, when you're debugging using the step over function, the compiler tries to jump to the end of the function, which generates an error since the address is not accessible. What it worked for me was to set a breakpoint after the function:

//your code

---

---

---

//--> once you get to this point while debugging, click the resume button

u8Status  = TPMS_READ_VOLTAGE(gu16UUMA);

BREAKPOINT HERE.

//-> now you're able to debug

I just did a quick test and it worked for me.

NOTE: As stated in page 141 of the datasheet, "One hardware address breakpoint built into BDC", you can only set ONE hardware address breakpoint, so I would recommend you to use one breakpoint at the time.

hope it helps.

Josh

0 Kudos

691 Views
loganchen
Contributor I

Dear Joshevelle

     Thanks for your reply.

     I think i find the reason.

     If i executed the Erase flash command, codewarrior would erase the address of Firmware Jump Table (0xE000-0xE03F).