Additional plug in's for codewarrior IDE

cancel
Showing results for 
Search instead for 
Did you mean: 

  Additional plug in's for codewarrior IDE

571 Views
rubykrishna
Contributor III

Hi,

 

Currently we have purchased around 5 floating license ( codewarrior development studio  : professional edition ) from NXP.We have procured other tools  like PC lint, QAC, TESSY, PTC INTEGRITY (MKS integrity : version control tool) .We need to bring all these tools in one single  environment. Our codewarrior IDE  supports only PC lint.Is it possible to integrate  other tools (QAC, TESSY, PTC_INTEGRITY)  in codewarrior IDE ?  We understood that  its a classic IDE. It won't support this plug in's ( correct me if i'm wrong)

Labels (1)
4 Replies

254 Views
trytohelp
NXP Employee
NXP Employee

Hi Ruby,

This is the problem with a proprietary IDE as CodeWarrior. Who is doing the plugins ?

We provides plugins for some tools as PC-Lint but not for other tools you're using.

You can ask the tools provider to know if they have plugins for CodeWarrior IDE.

Since 2010 we moved our product under Eclipse.

Depending of the devices you're using it could be interesting to move on Eclipse solution.

Tools manufacturer should provide Eclipse plugins.


Have a great day,
Pascal
NXP Technical Support

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

254 Views
rubykrishna
Contributor III

Hi Pascal,

Thanks for the reply.

We are using the following controllers for our development

MC9S12XHY256

MC9S12XEP100RMV

They come under HCS12/HCS12x  family. We are using codewarrior ide version 5.9.0 ( which is indeed a classic ide)  .

So latest eclipse based  codewarrior  ide support our controllers??

0 Kudos

254 Views
trytohelp
NXP Employee
NXP Employee

Hi Ruby,

Unfortunately only the HCS12Z family is supported under MCU V10.6.

For HCS12 family you need to use CW for HC12 v5.1 which is based on Classic IDE.

I recommend you to contact your tools vendors to know if they've a plugins for CodeWarrior IDE.

If plugins for CodeWarrior IDE is not available, is there another solution ?

I don't think but Eclipse is an open source and all build tool chain and debugger used in HC12 v5.1 can be used in standalone mode.

Last week I worked on a project where the goal was to create a project using HC12 tools under Eclipse.

For that I used CW for MCU V10.6 installation.

At the end I was able to build the project and launch the external debugger.

Does this can be used here ?

No idea ... adding plugins could introduce/open other questions/problems.

You can have a look to the link:

    Classic - Is it possible (How) to use HCS12 on Eclipse?


Have a great day,
Pascal
NXP Technical Support

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

254 Views
rubykrishna
Contributor III

to add it on,

i have seen codewarrior 10.6 but its not supporting our series of microcontrollers.

CodeWarrior for Microcontrollers-Eclipse IDE|NXP

0 Kudos