Can't Install Linux CW MCU 10.1 (Eclipse based) on my Gentoo Linux System....

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't Install Linux CW MCU 10.1 (Eclipse based) on my Gentoo Linux System....

316 Views
jrasmussen
Contributor II

Hello,

 

I'm trying to get Codewarrior installed on my Gentoo Linux system (as root).  It refuses to install claiming that it can't find a JRE java engine, However I do have a jre installed even though the linux setup doesn't accept it.  I have the JRE7_0_1 java jre from Oracle installed that other programs use without any problems.  Is there a particular version of the Java JRE that I need?  I believe my version is the 64-bit jre v7.0.1.

 

When I run the setuplinux file, I get the following error:

         This application requires a Java Run Time Environment (JRE)
          to run. Searching for one on your computer was not successful.
          Please use the command line switch -is:javahome to specify
          a valid JRE.  For more help use the option -is:help.


It doesn't seem to matter what I use for the -is:javahome option.  However, my jre is in the /usr/java directory and I've been trying:

setuplinux -is:javahome /usr/java/jre1.7.0

but I get the same error above.

 

I do have both Indigo Eclipse (M9 build) and TI Eclipse-based Code Composer Tools running on this machine, so I don't think I should be having java issues here.

 

What do I need to set to get setuplinux to see my java engine?

 

Thanks,

--James Rasmussen

Labels (1)
0 Kudos
2 Replies

35 Views
jrasmussen
Contributor II

Just checked and I see the exact same problem in the installation of CW MCU 10.2 Linux on my Gentoo System.

 

 

 

 

0 Kudos

35 Views
waferhead
Contributor I

Same issue installing on Mandriva 2010.2, seems oblivious to -is;javahome argument.

java works fine, tried oracles latest 1.7 down to openjdk, all work otherwise.

0 Kudos