CW v10.1 will not import my CW v5.1 projects (ColdFire)

cancel
Showing results for 
Search instead for 
Did you mean: 

CW v10.1 will not import my CW v5.1 projects (ColdFire)

523 Views
paul_carpenter
Contributor I

I have a project, or rather two projects whereby the output of one is used as an input to the other that are from legacy CW v5.1 (for ColdFire MCF5282). Using "CW Classic Project Importer". Selected my legacy project (.mcp) file then click Next. When I get to the next screen, "CodeWarrior Project Importer - Options", I see a red dot with an 'X' through it and the text next to it, "Error: unsupported settings panel version in VM map." The importer tool will not let me go any further.

I need to get this project imported so we may resume development of the legacy project on our new v10.1 tools.

Labels (1)
0 Kudos
4 Replies

88 Views
kavshi
Contributor II

We are also getting same error. How did you resolve it?

0 Kudos

88 Views
trytohelp
NXP Employee
NXP Employee

Hi

The CodeWarrior importer was provided on CW for MCU V10.0, V10.1 and V10.2.

The importer delivered on recent version as CW for MCU V10.6.4 is valid for DSC project only.

On older MCU V10.x versions, the importer was designed to import project running under last classic version - for each product:

    - CW for MCU V6.3,

    - CW for Coldfire V7.2,

    ...

If you're using an older version you can have some problems.

Depending of the project (complex one) you can have problem too.

To avoid all these problem the importer was discontinue since MCU V10.3

How to import classic project to Eclipse ?

There are 2 ANs explaining the process depending of the architecture used.

          AN4727, Import project from CW classic to CW MCU v10 4 CodeWarrior for Microcontrollers v10.4

                        http://cache.freescale.com/files/soft_dev_tools/doc/app_note/AN4727.pdf

          AN4104, Converting ColdFire Projects to CodeWarrior Development Studio for Microcontrollers V10.0

                        http://cache.freescale.com/files/soft_dev_tools/doc/app_note/AN4104.pdf

Hope this will help you.


Have a great day,
Pascal
Freescale Technical Support
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

88 Views
kwilson2107
Contributor II

Have you had any success with this? I'm getting the same error from a 6.3 project.

0 Kudos

88 Views
freescale_dude
Contributor II

The Project Importer will make its best guess and migrating the contents of a Classic CodeWarrior project, but there can be changes in run-time support and settings options in CW v10.x where a direct import of the old project is not possible. The error message in this case says that there are settings in the old project that can't be carried over intact to the new project.

 

Your best course of action is:

 

1) Create a new project in CW v10.x with the New Project wizard that is the closest match to the original project (MCU/MPU choice, memory model, and so on).

2) Copy the source files from the old project into the Sources folder of the new project in the CodeWarrior Projects view.

3) Make adjustments to the source files and settings to get the project to build correctly. For example, you will probably have to delete the default main.c file generated by the New Project wizard, unless your copy of the source files overwrote it.

 

---Tom

0 Kudos