ZIGBEE, Command and BeeAppUpdateDevice.

cancel
Showing results for 
Search instead for 
Did you mean: 

ZIGBEE, Command and BeeAppUpdateDevice.

212 Views
Braulio_Cespede
Contributor III

Greetings Everyone.

 

I was working with a Zigbee network, these are the devices, I currently working with.

 

MCU: MC13234

 

Devices:

ZR

ZED

 

I  was trying to send a OnOff command with a ZED device to the ZR to set a led light  ON, OFF or TOGGLE using the ZCL. But It did't work out.

 

I could send over the air from one device to another (ZED to ZR) without any trouble. The Problem  stater when I'm trying to use ZCL.

It get the message and them send a command to beeappupdated, but nothing happend.

 

I don't know what to do at this moment.

 

Screenshot from beeapp ZED:

This is the method I'm currently use:

13989_13989.jpg1.JPG.jpg

Note: the ClusterId is set up by ASL_ZclOnOffReq().

 

 

Screenshot from beeapp ZR:

13990_13990.jpg2.JPG.jpg

 

 

Screenshot from BeeAppDataIndication ZR:

13991_13991.jpg3.JPG.jpg

 

 

I repeat myself. IT SEND A COMMAND TO BEEAPPUPDATED event variable BUT IT DID NOT WORK.

Labels (1)
Tags (3)
0 Kudos
2 Replies

54 Views
AlanCollins
Contributor V

Hello Braulio,

You need to check the status return from the call "ASL_ZclOnOffReq()." Let me know which error you get. 

I see you are using gZbAddrModeGroup_c as addressing mode. This ignores the destination endpoint because this creates a broadcast using destination address as the 16-bit group you can to communicate with. This means you previously created a group with other remote devices.

If you want to use endpoints for addressing, you need to use gZbAddrModeIndirect_c as addressing mode.

Hope this helps.

54 Views
Braulio_Cespede
Contributor III

I'm already solved the problem.

It was simple, After i saw a example code. The problem was in the Attributes, I've never load.

Thanks for Answer.

0 Kudos