Processor doesn't start at reset vector after wakeup (stop1) with debugger

cancel
Showing results for 
Search instead for 
Did you mean: 

Processor doesn't start at reset vector after wakeup (stop1) with debugger

126 Views
Contributor I

Hi all,

 

I am using MPXY8300 chip with HCS08 core inside. What I experience at the moment is that program doesn't start from reset vector after waking up from the deepest low power mode aka. Stop1, but rather continues with execution after STOP command. The code sample is shown below:

 

void main(void) {   /* This code continously transmit TPMS packets of type VDO S1802020K */      UINT8 i;   volatile UINT8 tmp;   volatile UINT8 RFRD_data[11];   UINT16 delay=0;    PTADD |= BIT3;  // set pin A3 output   if (1){     LED_OFF;     LED_ON;     LED_OFF;   }      /* Set up MCU and set STOP mode. */   __RESET_WATCHDOG();      vfnSetupMCU();   vfnSetSTOPMode(1);    vfnSetupRFX();      EnableInterrupts;      LED_OFF;   LED_ON;   LED_OFF;     _asm STOP;   LED_OFF;   LED_ON;   LED_OFF;   while(1); } 

 

So when debugger is used, the code goes into while loop, while on execution without debugger it never reach while(1).

I was not able to find any information about this, and must admit that MPXY8300 documentation has a lo of errors.

 

Best,

Nemanja

Labels (1)
Tags (2)
0 Kudos
1 Reply

2 Views
NXP TechSupport
NXP TechSupport

Hi,

I ever made processor expert demo code on 9s08GB60

RTI interrupt can wake up stop3 every time. see attached sample code.

can this help?


Have a great day,
Zhang Jun

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos