Compile L3.0.35_4.1.0 on Ubuntu 14.04 64bit OS

Document created by Isaac Ng Employee on May 2, 2014Last modified by Isaac Ng Employee on Aug 10, 2014
Version 3Show Document
  • View in full screen mode

This is the procedure and patch to set up Ubuntu 14.04 64bit Linux Host PC and building i.MX6x L3.0.35_4.1.0. It has been tested to build GNOME profile and with FSL Standard MM Codec for i.MX6Q SDP with LVDS display.

 

Add suggestion about compiling "gstreamer-plugins-good" when selecting "Min profile" rootfs.  Please refer to the Note session.

 

A) Basic Requirement:

 

  • Set up the Linux Host PC using ubuntu-14.04-desktop-amd64.iso
  • Make sure the previous LTIB installation and the /opt/freescale have been removed

 

B) Installed the needed packages to the Linux Host PC


     Needed packages:

$ sudo apt-get install gettext libgtk2.0-dev rpm bison m4 libfreetype6-dev

$ sudo apt-get install libdbus-glib-1-dev liborbit2-dev intltool

$ sudo apt-get install ccache ncurses-dev zlib1g zlib1g-dev gcc g++ libtool

$ sudo apt-get install uuid-dev liblzo2-dev

$ sudo apt-get install tcl dpkg

$ sudo apt-get install asciidoc texlive-latex-base dblatex xutils-dev

$ sudo apt-get install texlive texinfo

$ sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0

$ sudo apt-get install libc6-dev-i386

$ sudo apt-get install u-boot-tools

$ sudo apt-get install scrollkeeper

 

$ sudo ln -s /usr/lib/x86_64-linux-gnu/librt.so   /usr/lib/librt.so

 

     Useful tools:

$ sudo apt-get install gparted

$ sudo apt-get install nfs-common nfs-kernel-server

$ sudo apt-get install git-core git-doc git-email git-gui gitk

$ sudo apt-get install meld atftpd

 

     Note: this operation "$ sudo ln -s /usr/lib/x86_64-linux-gnu/librt.so /usr/lib/librt.so" is used to fix rpm-fs build issue; which is taking reference from: LTIB - Strange problem building IMX6 Linux BSP from fresh on Ubuntu 13.10

 

 

C) Unpack and install the LTIB source package and assume done on the home directory:

 

$ cd ~

$ tar -zxvf L3.0.35_4.1.0_130816_source. tar.gz

$ ./L3.0.35_4.1.0_130816_source/install

 

D) Apply the patch to make L3.0.35_4.1.0 could be installed and compiled on Ubuntu 14.04 64bit OS


$ cd ~/ltib

$ git apply 0001_make_L3.0.35_4.1.0_compile_on_Ubuntu_14.04_64bit_OS


What the patch is doing:


a) The patch modifies the following files:

    • bin/Ltibutils.pm
    • dist/lfs-5.1/base_libs/base_libs.spec
    • dist/lfs-5.1/m4/m4.spec
    • dist/lfs-5.1/ncurses/ncurses.spec
    • dist/lfs-5.1/openssl/openssl.spec
    • dist/lfs-5.1/xorg-server/xorg-server.spec


b) Add the following files to the pkgs directory:

    • pkgs/m4-1.4.16-1383761043.patch
    • pkgs/m4-1.4.16-1383761043.patch.md5
    • pkgs/openssl-1.0.1c-1398677566.patch
    • pkgs/openssl-1.0.1c-1398677566.patch.md5
    • pkgs/xorg-server-1.6.1-1398785267.patch
    • pkgs/xorg-server-1.6.1-1398785267.patch.md5

 

E) Then, it is ready to proceed the rest of the LTIB env setup process:


$ cd ~/ltib

$ ./ltib -m config

$ ./ltib


F) about the patch:

 

  • LTIB script warning when running with Perl v5.18.2
    • associated change:
      • bin/Ltibutils.pm
    • description:

It prints out the following warning when doing package unpack, the patch is used to remove the warning.

 

defined(@array) is deprecated at bin/Ltibutils.pm line 259

        (Maybe you should just omit the defined()?)

 

 


 

 


 

  • xorg-server configuration fail:
    • associated change:
      • dist/lfs-5.1/xorg-server/xorg-server.spec
      • pkgs/xorg-server-1.6.1-1398785267.patch
      • pkgs/xorg-server-1.6.1-1398785267.patch.md5
    • description: When doing configuration, it stops at saying tslib not found.  It could be fixed by adding -dl when doing tslib test in configuration stage.


NOTE:

 

A) During the LTIB setup and compilation, these warnings were pop up.  Just ignore them and it seems okay.


panel01.jpg


panel2.jpg



B) the dist/lfs-5.1/gst-plugins-good.spec is used to configurate/compile/install the "gstreamer-plugins-good" package.  It set up the environment variables pointing to libcairo but disable it when doing configuration. Thus, libcairo is actually not being used.


          Clipboard011.jpg

In Gnome profile, cario has been selected by default.  Thus, it does not experience the problem when compiling "gstreamer-plugins-good".


However, in Min profile, if you select gstreamer-plugins-good to compile and install to your rootfs but without selecting cario as well, you will experience the error described in this thread: Re: gst-fsl-plugins build failed


Thus, you could follow the solution provide in the Re: gst-fsl-plugins build failed or simply select cairo in your package list.


          Clipboard0111.jpg

1 person found this helpful

Outcomes