AnsweredAssumed Answered

How to use Mfgtool with a Yocto i.MX6 build

Question asked by Simon Rogers on Jan 10, 2017
Latest reply on Jan 23, 2017 by Yuri Muhin

I have used Mfgtool to reflash i.MX6 on a previous (non-Yocto) project where we successfully built everything from source (U-boot 2009.08).

We are now using Yocto Fido to successfully produce an SD card image for our Hummingboard (U-boot 2013.10, Kernel 3.14.60).

I would like to use Mfgtool again, this time to program our Hummingboard eMMC flash memory, but I'm struggling with generating a U-boot image that will transfer/boot over USB/mfgtool.

 

Questions:

  1. meta-fsl-arm/recipes-bsp/u-boot/u-boot-imx-mfgtool_2014.04.bb looks like just what I need to build a U-boot for Mfgtool. But this recipe does not build anything and generates empty rpm packages. Is this recipe broken for fido? Should it generate a U-boot for Mfgtool? I've tried the usual tricks e.g. bitbake u-boot-imx-mfgtool -c compile -f. I see the unpack and configure but nothing ever gets built.
  2. Are the instructions in the Firmware Development Guide still valid/correct? I've modified my U-boot 2013.10 as per the instructions, but the U-boot.bin produced won't boot/transfer over USB. I've then tried building the .imx file but this also doesn't work (stuck at 'Loading U-boot'). Are these instruction only applicable to a certain U-boot version? 
  3. How do NXP recommend I build a U-boot for Mfgtool serial boot? Specifically which U-boot versions are compatible with Mfgtool2 and what is the i.MX6 expecting (the .bin, the .imx, IVT headers etc).
  4. Should we all be giving up with Mfgtool and instead using the new U-boot UMS (USB Mass Storage) support?

 

Thanks

Simon

Outcomes