BOB SCHMANSKI

CFFlasher "Could not initialize BDM Device"

Discussion created by BOB SCHMANSKI on Mar 5, 2007
Latest reply on Apr 30, 2007 by Francisco Perea
Hi Everybody.

I'm hoping someone has experienced a similar problem and/or can help me figure out where I'm going wrong. I am trying to resurrect a M5249C3 development board with a corrupted flash. I am absolutely unable to get the CFFlasher program to do anything useful. I downloaded v3.1 from freescale's web site, as well as P&E's hardware device drivers. I have a P&E Coldfire "LV" cable and a Dell Optiplex PC with Windows XP Pro. I have used this cable successfully to debug many CF processors using SDS (now WindRiver) SingleStep, including MCF5206e and MCF5249, so I'm pretty sure my PC, parallel port, and BDM cable are up to the task.

Here's what I've tried:
When I run the CFFlasher program, I click Target Config, select "M5249C3" as the target, and select "PE_LPT" in "BDM Communication". I try clicking on "Configure" to set up the LPT port and such, but absolutely nothing happens when I click the button (not a good sign). I click OK to return to the main CFFlasher window. At this point, any time I try to do anythign useful (click on "Memory Window" or "Upload" or click "Program" then "Program" or "Erase" then "Erase" or "Fill" then "Fill" ), I get the "Could not initialize BDM device" message.

I also downloaded and ran "driver_test" from pemicro.com, and got the following results:
(detected) C:\WINDOWS\inf\Pemicro_usbcable_auto.inf (11/18/2003)
(detected) C:\WINDOWS\inf\CycloneProR1.inf (3/22/2005)
(detected) C:\WINDOWS\inf\windrvr6.inf (4/21/2005)
(detected) C:\WINDOWS\inf\usbmultilink_rev20.inf (7/15/2004)
(detected) C:\WINDOWS\system32\SENDKEY.DLL (5/29/1996)
(detected) C:\WINDOWS\system32\pedrv.vxd (7/24/2000)
(detected) C:\WINDOWS\system32\vichw11.vxd (8/28/1998)
(detected) C:\WINDOWS\system32\PEUSBFTDUN.EXE (Version 2.00)
(detected) C:\WINDOWS\system32\PEUSBV1.DLL (Version 2.00)
(detected) C:\WINDOWS\system32\PEUSBWD1.DLL (Version 6.02)
(detected) C:\WINDOWS\system32\PEUSBWD2.DLL (Version 7.00)
(detected) C:\WINDOWS\system32\drivers\giveio.sys (4/3/1996)
(detected) C:\WINDOWS\system32\drivers\pedrv.sys (8/3/2000)
(detected) C:\WINDOWS\system32\drivers\WINDRVR6.SYS (Version 7.00)
(detected) C:\WINDOWS\system32\drivers\vichw11.sys (10/2/1998)
(detected) C:\WINDOWS\system32\drivers\PEUSBV1.SYS (Version 1.04)

I've also downloaded and run the windows registery patch from pemicro.com to disable Windows XP's "polling" of the parallel port. I also went into my BIOS and set the parallel port to "AT" type (though having it set to EPP or ECP has never caused problems with my other BDM usage with SDS SingleStep).

Can anyone give me any ideas?

Thanks,
Bob

Outcomes