How to recover S32K148 while debugger can not connect to target

cancel
Showing results for 
Search instead for 
Did you mean: 

How to recover S32K148 while debugger can not connect to target

631 Views
marcin_krzemins
Contributor I

My image builder tool has created wrong srec binary. After flashing one it is impossible to connect to S32K148 (using J-Link and P&E micro).

I have already tried:

  • "Emergency Kinetis Device Recover by Full Chip Erase" option with P&E and S32DS
  • "Kinetis_Recovery_Utility" with P&E does not do the trick for me.
  • "unlock kinetis" from J-Commander or J-Flash can not erase flash.
  • J-Link command with the script (erase_all_pin.jlk) from topic: https://community.nxp.com/thread/439921?commentID=857127#comment-857127 can not solve the issue (full logs attached):

From MDM-AP Status register (0x34) looks like System is in reset state, system security is enabled and fortunately mass erase is still enabled. I find that mass erase is not working because "Flash memory ready" bit is not set. I assume it is because from some reason processor did not boot.

Is it possible to somehow rescue this chip in this circumstances? What else can I check?

Labels (1)
Tags (2)
0 Kudos
1 Reply

258 Views
pchui
Contributor I

Hi Marcin,

I have a S32K148 EVB that won't connect to either PE Micro or J-Link after running firmware that may have misconfigured the flash. I also tried the same four techniques that you tried to unbrick it. Did you a find a solution to recover your system?

Thanks.

Paul

0 Kudos