How to compile u-boot-2020.04.tar.bz2 to generate uboot image supporting PPC P2020?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to compile u-boot-2020.04.tar.bz2 to generate uboot image supporting PPC P2020?

164 Views
xiaocheng
Contributor II
Hello,
 
I downloaded u-boot-2020.04.tar.bz2, but I unzipped it to ubuntu14.04 64bit and the following operation reported an error:

make TQM823L_defconfig Makefile:37: *** missing separator. Stop.

My current system information:

uname -a Linux ubuntu 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

 

My purpose is to compile this u-boot-2020.04.tar.bz2 to generate a uboot image of the powerpc P2020 processor (such as u-boot-2020.04\board\freescale\p1_p2_rdb_pc), Please give detailed instructions on how to compile and generate uboot image files?

For example, which compiler toolchain is installed, what patches are needed (or which version of the system to use directly), and how to compile?

Thank you very much.

0 Kudos
3 Replies

155 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please download ISO "Image: QorIQ Linux SDK v2.0 PPCE500V2 IMAGE" from "https://www.nxp.com/design/software/embedded-software/linux-software-and-development-tools/linux-sdk... , then mount this ISO and run the script in fsl-toolchain/ folder to install Toolchain for PPCE500V2 platform.

$ source /opt/fsl-qoriq/2.0/environment-setup-ppce500v2-fsl-linux-gnuspe

Go to u-boot source code folder build image with the following command.

$ make P2020RDB-PC_defconfig

$ make COSS_COMPILE=powerpc-fsl-linux-gnuspe-

Tags (1)
0 Kudos

138 Views
xiaocheng
Contributor II

Hi,yipingwang,

Thank you for your reply.

/fsl-qoriq-glibc-i686-ppce500v2-toolchain-2.0.sh keeps stopping in "Setting it up..." .

Then it is empty under /opt/fsl-qoriq/2.0/environment-setup-ppce500v2-fsl-linux-gnuspe. Could I possibly have done something wrong?

 

Here is the log:

[root@localhost fsl-toolchain]# ls -l
总计 256470
-r-xr-xr-x 1 root root 132730048 2016-05-23 fsl-qoriq-glibc-i686-ppce500v2-toolchain-2.0.sh
-r-xr-xr-x 1 root root 129894781 2016-05-23 fsl-qoriq-glibc-x86_64-ppce500v2-toolchain-2.0.sh
[root@localhost fsl-toolchain]# ./fsl-qoriq-glibc-i686-ppce500v2-toolchain-2.0.sh
sort:无效选项 -- V
请尝试执行“sort --help”来获取更多信息。
QorIQ SDK (FSL Reference Distro) SDK installer version 2.0
==========================================================
Enter target directory for SDK (default: /opt/fsl-qoriq/2.0):
The directory "/opt/fsl-qoriq/2.0" already contains a SDK for this architecture.
If you continue, existing files will be overwritten! Proceed[y/N]? Y
Extracting SDK...tar:选项“--checkpoint”不接受参数
Try `tar --help' or `tar --usage' for more information.
done
Setting it up...

0 Kudos

105 Views
yipingwang
NXP TechSupport
NXP TechSupport

What Linux OS are you using?

Probably the Toolchain installation script is not compatible with your Linux OS.

SDK 2.0 has already been verified on the following machine.

Ubuntu 14.04, CentOS-7.1.1503,
Debian 8.2, Fedora 22 and OpenSUSE 13.2

 

I also verified the Toolchain installation script on Ubuntu 16.04 and Ubuntu 18.04.

0 Kudos