Problem with installing QorIQ-SDK-V1.4-SOURCE-20130625-yocto

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with installing QorIQ-SDK-V1.4-SOURCE-20130625-yocto

335 Views
victorgomez
Contributor II

Hi folks,I am running into a weird error when installing the QorIQ-SDK-V1.4-SOURCE-20130625-yocto.iso package.

I am installing it on my Fedora 20. And I did this:

1) Mounted the ISO

2) Executed the installation: /mnt/qoriq_yocto_1.4_source/install

3) CDed into the installation directory: <install_path>/qoriq-linux/fsc-sdk-1.4/QorIQ-SDK-V1.4-20130625-yocto

Up to here, everything worked like a charm, getting this message:

Done. You're ready to go with Yocto build now

250.207u 56.173s 34:07.18 14.9% 0+0k 3378300+5841776io 1363pf+0w

Now, I do the following:

source ./fsl-setup-poky -m p4080ds -j 12 -t 12 -l

And I get this error:

{local@host:55} source ./fsl-setup-poky -m p4080ds -j 12 -t 12 -l

Badly placed ()'s.

I get a "Badly placed ()'s error. I checked the fsl-setup-poky file, and I didn't see any misplaced () or any bug that was easy to see.

Do you have any ideas?

ANy help is much appreciated!
Thank you!
Best,
Victor.

Labels (1)
0 Kudos
2 Replies

39 Views
Pavel
NXP TechSupport
NXP TechSupport

We recommend using Ununtu 12.04 for SDK building.

The following command sequence is recommended for SDK installing.

  1. 1. sudo apt-get install ubuntu-minimal ubuntu-standard patch vim-common sed wget subversion git-core coreutils libbonobo2-common unzip texi2html texinfo libsdl1.2-dev docbook-utils gawk python-pysqlite2 diffstat make gcc build-essential xz-utils g++ desktop-file-utils chrpath libgl1-mesa-dev libglu1-mesa-dev autoconf automake groff libtool xterm libncurses5-dev cvs tofrodos

    if it is 64-bit operating system, run the following command also:

    sudo apt-get install ia32-libs lib32ncurses5

  1. 2.  sudo dpkg-reconfigure dash

then choose "No" and you're done. )

  1. 3. install SDK for your core (500V2 or 5500). For example the QorIQ Linux SDK v1.4 e500mc Yocto Cache Binary ISO.
  2. 4. install SDK source
  3. 5. sudo ./scripts/host-prepare.sh
  4. 6. usually Linux recommends also run the following command: sudo usr/sbin/visudo

  1. 7.  $ source ./fsl-setup-poky <-m machine> [-j threads] [-t tasks] [-l]

      * <-m machine> is mandatory, [-j threads], [-t tasks], [-h] and [-l] are optional

      * [-j threads]: the number of threads to have the make program itself spawn during the compilation stage. Set -j equal to 1.5 * (number of CPU cores), rounded up to the nearest integer.

      * [-t tasks]: the maximum number of BitBake tasks that can be issued in parallel. Set -t equal to the number of CPU CORES that you have.

      * [-l]: lite mode. To help conserve disk space, deletes the building directory once the package is built.

      * [-h]: help. If given, other options will be omitted.

For example: source ./fsl-setup-poky -m p2020ds

    $ bitbake <task-name>

Test similar command sequence on the Fedora 20.

0 Kudos

39 Views
victorgomez
Contributor II

Hi Pavel

Thanks for the detailed information. Much appreciated! Unfortunately I still get the same error, and I have followed all your steps. I will try now to move to an Ubuntu system, see if that makes a difference.

Thanks!

Victor.

0 Kudos