Cannot flash or debug Devkit ZVL128 with Code Warrior

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot flash or debug Devkit ZVL128 with Code Warrior

Jump to solution
235 Views
Contributor II

Dear all,

I recently received a new Devkit ZVL128, but when trying to flash it using CodeWarrior, the following error appear : 

"an invalid preference was passed to the GDI protocol plugin(HC/RS/S12Z GDI Protocol Adapter) Error: command failed " (See attached file)
 
I also tried to enter debug mode on a example project and I got stuck in an endless loop. (See attached file)
 
Any clues ?
 
Regards,
Matisse
1 Solution
143 Views
Contributor II
Spoiler
 

Problem solved : I ordered a ZVL32 instead of a 128.

View solution in original post

0 Kudos
3 Replies
219 Views
NXP TechSupport
NXP TechSupport

Dear Matisse,

 

At first, could you please, try to create a new project for S12ZVL128 and try to load the project into MCU using debug configuration option?

dianabatrlova_0-1601989756987.png

 

Which PE micro multilink do you use?

 

Thank you.

Best regards,

Diana

0 Kudos
153 Views
Contributor II

Dear dianabatrlova, thank you for your answer,

As mentionned above, If I try to enter debug mode, Code Warrior gets stuck in an endless loop, even with a new project ( Verifying object file CRC-16 to device ranges ...
INF: block 00FE0000-00FE0120 ...)

I tried to flash/debug with the onboard debugger and with an external PE multilink debugger, same issue occurs.

Regards,

Matisse

0 Kudos
144 Views
Contributor II
Spoiler
 

Problem solved : I ordered a ZVL32 instead of a 128.

View solution in original post

0 Kudos