How do I start with the frdm kl43z platform?

cancel
Showing results for 
Search instead for 
Did you mean: 

How do I start with the frdm kl43z platform?

Jump to solution
485 Views
kennethgraakjær
Contributor II

Hi

 

I am having serious difficulties with the kl43z. In the sense that I cannot seem to get in contact with at all.

 

I have installed KDS together with the KSDK_1.0.0-KL43Z package. Furthermore in KDS I have installed the board support package from the SDK together with Eclipse update for KSDK, MQX Plug-ins and Processor Expert Software. I have tried putting together a Hello World project which doesn't do anything besides compile without errors but there does not seem to be a way to get the resulting .elf file to the board.

 

I have tried the following in getting the file to the board:

1) I have tried to use PEMicro for the debugging interface and setting it to OpenSDA Embedded Debug - USB PORT and selecting the correct board from the dropdown menu. It ends with the following message: PE-ERROR: Unable to auto-detect debug hardware. Please specify on the command-line. Halting.

 

2) I have tried to start the board in bootloader mode (holding down reset before powering it on with the USB in the OpenSDA port) and copy the file directly to the board. Nothing happened.

 

It should be noted that I am using 64bit Ubuntu and KDS for this. If there is any documentation on how to use the command line and the SDK directly that would be fine too. I have not been able to find anything on this either.

 

I have searched for hours on end for a simple start guide on how to get anywhere with kds without any luck. So now, here I am, bugging you.

 

Please help.

 

kenneth

Labels (1)
0 Kudos
1 Solution
149 Views
kennethgraakjær
Contributor II

The problem went away after I updated the boot loader. On the drive which appears when I plug in the board there was a link to where  I could download them. I believe the version before update was in the vecinity of 1.06.

After the update debugging works perfectly in kds.

View solution in original post

0 Kudos
3 Replies
150 Views
kennethgraakjær
Contributor II

The problem went away after I updated the boot loader. On the drive which appears when I plug in the board there was a link to where  I could download them. I believe the version before update was in the vecinity of 1.06.

After the update debugging works perfectly in kds.

View solution in original post

0 Kudos
149 Views
Rick_Li
NXP Employee
NXP Employee

Hi Kenneth,

Could you please try the below steps:

1) in KDS IDE, right click your project and then "Debug As"->"Debug Configuration..."

2) select your device name and then debug, see below image (it was a project for k22, so, please specify your target devicce):

hope it helps!

pastedImage_0.png

0 Kudos
149 Views
kennethgraakjær
Contributor II

That was what I was trying to explain in point 2 above.

When I do that (and select the board as kl43z256m4 (from memory, it may be slightly different) it gives me the following error:

PE-ERROR: Unable to auto-detect debug hardware. Please specify on the command-line. Halting.

I tried from a base install of kds and I tried to install the linux drivers from the PEMicro homepage. Same result in both cases.

0 Kudos