AnsweredAssumed Answered

HDMI display not working in i.MX 8M Quad EVM

Question asked by Gopinath Srinivasan on Aug 10, 2018
Latest reply on Aug 24, 2018 by Gopinath Srinivasan

Hello Everyone,

 

I brought the i.MX 8M EVM and boot the default Android image flashed in the eMMC. It looks Android OS is booted successfully but the I cannot see the HDMI output in my 1080P HDMI monitor. But as per the Quick start guide, Android logo will appear on the HDMI display by default. Can anyone help me on this issue?

 

Below is the other information for your reference.

 

Version details:

u-boot

U-Boot SPL 2017.03 (Jan 24 2018 - 01:18:13)

Kernel 

Linux version 4.9.68 (bamboo@shlinux23)

ASOP 

ro.build.id=1.3.0-prc-rc2
ro.build.display.id=evk_8mq-userdebug 8.0.0 1.3.0-prc-rc2 20180110 dev-keys
ro.build.version.incremental=20180110
ro.build.version.sdk=26
ro.build.version.preview_sdk=0
ro.build.version.codename=REL
ro.build.version.all_codenames=REL
ro.build.version.release=8.0.0

 

I am getting below dmesg output continuously. 


[ 1458.233876] [drm] HDMI/DP Cable Plug In
[ 1469.221881] [drm] HDMI/DP Cable Plug In
[ 1480.209875] [drm] HDMI/DP Cable Plug In
[ 1491.197879] [drm] HDMI/DP Cable Plug In
[ 1502.181873] [drm] HDMI/DP Cable Plug In
[ 1513.169879] [drm] HDMI/DP Cable Plug In
[ 1524.157871] [drm] HDMI/DP Cable Plug In
[ 1535.141872] [drm] HDMI/DP Cable Plug In
[ 1546.129883] [drm] HDMI/DP Cable Plug In
[ 1557.117876] [drm] HDMI/DP Cable Plug In
[ 1568.101933] [drm] HDMI/DP Cable Plug In
[ 1579.089871] [drm] HDMI/DP Cable Plug In

 

By the way, I tried the suggestions from previous related threads. Unfortunately no success.    

 

Your suggestions are greatly appreciated. Thank You.

 

Regards,

Gopinath S

Outcomes