mxc_vpu_test on i.MX6Q Android returns error

cancel
Showing results for 
Search instead for 
Did you mean: 

mxc_vpu_test on i.MX6Q Android returns error

1,242 Views
williamho
Contributor II

Dear all,

I am working on a i.MX6Q Android board recently.

My Android platform built from IMX6_JB422_100 BSP.

I found a test tool in BSP: mxc_vpu_test

But it always returns error.

Is there anyone has experience of this tool?

Error message looks like:

mxc_vpu_test -D 'akiyo.mp4 -f 4'

[INFO]    VPU test program built on Nov 12 2009 11:17:18

[INFO]    VPU firmware version: 2.3.10

[INFO]    VPU library version: 40778.5.4

[INFO]    Format: STD_MPEG4

[INFO]    MPEG4 class: MPEG4

[INFO]    decoder listening on port 5555

[ERR]    vpu_DecOpen failed

Labels (2)
Tags (2)
0 Kudos
4 Replies

230 Views
yangthomas
Contributor II

Do you slove it?

0 Kudos

230 Views
williamho
Contributor II

I got the answer by myself.

The mxc_vpu_test comes from ./device/fsl-proprietary/test/bin/* always returns error.

And you will got the same binary file in every full build which doesn't work.

I rebuild the mxc_vpu_test from the source folder, and got the correct binary: mxc-vpu-test !

0 Kudos

230 Views
johnturnur
Contributor III

Hi,

Where is the  source code available?

FreescaleJB\external\linux-test\test\mxc_vpu_test?

How did you build it?

0 Kudos

230 Views
williamho
Contributor II

Yes, the source folder is (BSP TOP) ./external/linux-test/test/mxc_vpu_test .

I build binary with tools 'mm', which comes from ./build/envsetup.sh

And you will got: "mxc-vpu-test". 

0 Kudos