Help about install python-pyqt5

cancel
Showing results for 
Search instead for 
Did you mean: 

Help about install python-pyqt5

436 Views
Contributor III

Hi every.
I am adding python-pyqt5 by modifying local.conf:
  IMAGE_INSTALL_append + = "python-pyqt5"
but it not work. Error log below:

Build Configuration:
BB_VERSION           = "1.38.0"
BUILD_SYS            = "x86_64-linux"
NATIVELSBSTRING      = "ubuntu-16.04"
TARGET_SYS           = "aarch64-poky-linux"
MACHINE              = "imx8mmevk"
DISTRO               = "fsl-imx-xwayland"
DISTRO_VERSION       = "4.14-sumo"
TUNE_FEATURES        = "aarch64"
TARGET_FPU           = ""
meta                
meta-poky            = "HEAD:c9bd4984f8f471ca2c43052714f4413ba99cf171"
meta-oe              
meta-multimedia      = "HEAD:8760facba1bceb299b3613b8955621ddaa3d4c3f"
meta-freescale       = "HEAD:27ca94f8a4336790ba117b4298566f6820e7e74c"
meta-freescale-3rdparty = "HEAD:82037216280a39957fb4272581637abec734ad50"
meta-freescale-distro = "HEAD:f7e2216e93aff14ac32728a13637a48df436b7f4"
meta-bsp            
meta-sdk             = "HEAD:8eeb420fad668b733ab95b460895e1c337c66b25"
meta-browser         = "HEAD:75640e14e325479c076b6272b646be7a239c18aa"
meta-gnome          
meta-networking      
meta-python          
meta-filesystems     = "HEAD:8760facba1bceb299b3613b8955621ddaa3d4c3f"
meta-qt5             = "HEAD:d4e7f73d04e8448d326b6f89908701e304e37d65"
meta-webserver       = "HEAD:8760facba1bceb299b3613b8955621ddaa3d4c3f"
meta-imx-machinelearning = "HEAD:7e9294dead55d1f6b4f1cfe486e0c4e0c5097953"
meta-java            = "sumo:a6f135f7ac72fbaea2a02986dd9c18df720bf3fa"

Initialising tasks: 100% |#######################################| Time: 0:00:01
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks
ERROR: python-pyqt5-5.8.2-r0 do_configure: Function failed: do_configure (log file is located at /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/temp/log.do_configure.2010)
ERROR: Logfile of failure stored in: /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/temp/log.do_configure.2010
Log data follows:
| DEBUG: Executing shell function qmake5_base_preconfigure
| DEBUG: Shell function qmake5_base_preconfigure finished
| DEBUG: Executing shell function do_configure
| Querying qmake about your Qt installation...
| Reading configuration from
| /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/PyQt5_gpl-5.8.2/pyqt.cfg...
| This is the GPL version of PyQt 5.8.2 (licensed under the GNU General Public
| License) for Python 2.7.15 on linux2.
|
| Type 'L' to view the license.
| Type 'yes' to accept the terms of the license.
| Type 'no' to decline the terms of the license.
|
| Do you accept the terms of the license? Error: Unable to create the C++ code.
| Found the license file pyqt-gpl.sip.
| Checking to see if the dbus support module should be built...
| pkg-config --cflags-only-I --libs dbus-1
| The Python dbus module doesn't seem to be installed.
| Qt v5.10.1 is being used.
| The qmake executable is
| /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/recipe-sysroot-native/usr/bin/qt5/qmake.
| Qt is built as a shared library.
| The system root directory is
| /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/recipe-sysroot.
| SIP 4.19.19 is being used.
| The sip executable is
| /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/recipe-sysroot-native/usr/bin/sip.
| These PyQt5 modules will be built: QtCore, QtGui, QtNetwork, QtWidgets.
| The PyQt5 Python package will be installed in
| /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/image//usr/lib/python2.7/site-packages.
| PyQt5 is being built with generated docstrings.
| PyQt5 is being built with 'protected' redefined as 'public'.
| The Designer plugin will be installed in
| /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/recipe-sysroot/usr/lib/qt5/plugins/designer.
| The qmlscene plugin will be installed in
| /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/recipe-sysroot/usr/lib/qt5/plugins/PyQt5.
| The PyQt5 .sip files will be installed in
| /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/image//usr/share/sip/PyQt5.
| pyuic5, pyrcc5 and pylupdate5 will be installed in
| /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/image//usr/bin.
| The interpreter used by pyuic5 is
| /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/image//usr/bin/python2.7.
| Generating the C++ source for the QtCore module...
| /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/recipe-sysroot-native/usr/bin/sip -w -f -x VendorID -t WS_X11 -t Qt_5_10_1 -x PyQt_Desktop_OpenGL -x PyQt_Accessibility -x PyQt_SessionManager -x Py_v3 -B Qt_6_0_0 -P -o -c /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/PyQt5_gpl-5.8.2/QtCore -I sip -I /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/PyQt5_gpl-5.8.2/sip /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/PyQt5_gpl-5.8.2/sip/QtCore/QtCoremod.sip
| sip: Deprecation warning: the -B flag is deprecated
| WARNING: exit code 1 from a shell command.
| ERROR: Function failed: do_configure (log file is located at /home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/build-xwayland/tmp/work/aarch64-poky-linux/python-pyqt5/5.8.2-r0/temp/log.do_configure.2010)
ERROR: Task (/home/hinoeng/imx-yocto/fsl-arm-yocto-bsp/sources/meta-qt5/recipes-python/pyqt5/python-pyqt5_5.8.2.bb:do_configure) failed with exit code '1'

Anybody could you tell me how to fix this issue?
Thank you.

Tags (3)
1 Reply

154 Views
NXP TechSupport
NXP TechSupport

Hi タイ チャン ,

    I compiled L4.14.98 BSP with QT , and added following line to local.conf.

    IMAGE_INSTALL_append + = " python-pyqt5" ( Note: before python-pyqt5, there is a space character)

    50% complete now, no error.

pastedImage_3.png

Try it , please!

Have a nice day!

BR,

Weidong