Accessing CAN Issue in IMX6ULL- evk yocto

cancel
Showing results for 
Search instead for 
Did you mean: 

Accessing CAN Issue in IMX6ULL- evk yocto

1,470 Views
bipulpandey
Contributor I

Hi,

I am having an issue to accessing CAN in our hardware while building the yocto image for imx6ul7d. when I used the prebuilt image of imxul7d(rocko) I am able to access CAN.

The driver is enumerated and I am able to find in ip link 

root@imx6ul7d:~# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: can0: <NOARP40000> mtu 16 qdisc noop qlen 10
link/[280]
3: can1: <NOARP40000> mtu 16 qdisc noop qlen 10
link/[280]

But when I tried to set the IP, I get an error 

root@imx6ul7d:~# ip link set can0 up type can bitrate 125000
ip: either "dev" is duplicate, or "type" is garbage 

However, I am able to set the bitrate prebuilt image. 

Here is the summery 

1. take the prebuilt the image imx6ul7d able to communicate through CAN 

2. Setup the environment fro yocto follow the document  "i.MX_Yocto_Project_User's_Guide"  for imx6uul evk.

3. check all the component of CAN and iproute2 and found everything is fine.

4. checked with rocko, sumo, thud but same issue.

5. I am taken all the documentation form imx6uulevk 

6. I have checked with imx6ull evk and imx6ul7d but same result. 

what needs to be changed so that I can set bitrate 

what is this issue so we are getting NOARP40000 

Labels (2)
0 Kudos
4 Replies

554 Views
adamhuang
Contributor III

Similar issue encountered.

0 Kudos

1,127 Views
bipulpandey
Contributor I

Please let me know if there is any solution for the same

Thanks for advance 

0 Kudos

1,127 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hi bipul,

Do not know the Mx6ul7d but I have worked with FlexCAN; If you do the next:

 

ip -s -d link show can0

 

You should get more info about the CAN module state, like if either is in error active or passive mode.

may be useful to check

All Boards FlexCAN 

also one can try with "canutils" package

can-utils/README.md at master · linux-can/can-utils · GitHub 

 

Best regards

0 Kudos

1,127 Views
bipulpandey
Contributor I

Thanks

I am getting this output

root@imx6ul7d:~# ip -s -d link show can0
BusyBox v1.24.1 (2019-02-18 19:05:54 UTC) multi-call binary.

Usage: ip [OPTIONS] {address | route | link | tunnel | } {COMMAND}

Though I am having Flexcan only 

we have an entry in net 

root@imx6ul7d:/# cd sys/class/net/
root@imx6ul7d:/sys/class/net# ls
can0 can1 eth0 eth1 lo sit0 

I am using the busy box version V1.24.1

As I have mentioned we can communicate with CAN when I used a prebuilt image 

0 Kudos