SPI interface 56F8367

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

SPI interface 56F8367

1,285 Views
Charlie
Contributor III
I am using both the SPI interfaces.  One is for writing to a serial DAC and another is for interprocessor communications.

I have the DAC SPI interface running fine, however, I cannot get the other one to work.

I mimic the status and control register, the data size and the interrupt (respective) registers.  I have stopped the unit and looked at the registers (the 4 for the SPI interface and the two IPRs) and they are exactly the same.  I know I am getting to the code I need to get to through breakpoints.  I access the units in the same exact way.  Yet, only one works, and I have tried two different boards.

I just don't get it.

Any ideas?  Is there something about the SPI interface that I am missing?  Or, I guess, that I got right on one and forgot about on the other?
0 Kudos
1 Reply

519 Views
Pedro_
Contributor III
I haven't worked with this processor but I've seen a problem like this before.
 
Have you scoped the Chip Select line of the interprocessor comms?
Make sure there's no significant noise in it.
 
Regards
0 Kudos