Error Derivative can NOT be unsecured!

cancel
Showing results for 
Search instead for 
Did you mean: 

Error Derivative can NOT be unsecured!

2,073 Views
admin
Specialist II

Hi guys,

I am getting this error message when attemping to load code into Flash, it appears that there is an error in the

 

HCS08_OpenSourceBDM_Erase_Unsecure.cmd

 

file.

 

In the Real-Time Debugger Command window it indicates that the line

 

=========================================================================

 

wb 0x1802 3     // disable COP clearing SIMOPT register + set BKGDPE and RSTPE (when available)
 

ILLEGAL_BP

 

=========================================================================

Has anyone else encountered this problem?

 

Thanks in advance!

 

Derivative_could_NOT_be_unsecured.jpg

cmd_1.jpg

cmd_2.jpg

Message Edited by t.dowe on 2009-10-26 04:42 PM
Tags (2)
0 Kudos
1 Reply

47 Views
Ari
Contributor I

I'm having the same problem here. I've recently built an OSBDM with a JB16, and loaded the v2 firmware. I'm testing the BDM tool to check that it works with a simple blinking led on a S08SH8 uC.

The HIWAVE part of CW returns the same error when i attempt to program the SH8. I'm not shure what's the original internal clock, because the CW ask me to enter a paremeter for the FCDIV when i want to "unsecure" the chip.

 

The command line is constantly showing a  "Target Speed Change Detected - New Speed ...", where the speed change range from 18.00 to 18.20 MHz.

 

Now, doing the math as shown on the FCDIV window, i've set up that parameter as 76, but it still doesn't work.

 

Does anybody knows what may be wrong? Is the .cmd file correct? The command line returns that the unsecure command is correctly executed, but i cannot program the device. :smileyfrustrated:

 

Thanks to whoever can help solve this problem.

 

Ps.: I'm sorry if there is any spelling or syntax mistake with my english. =D 

0 Kudos