can not generate .elf after build in simulink

cancel
Showing results for 
Search instead for 
Did you mean: 

can not generate .elf after build in simulink

305 Views
Contributor II

Hello, I used MBD Toolbox for MPC574xP in simulink. And I want to flash the .elf file to the board. But after build in MATLAB, I can't find the .elf file in the xxx_rtw folder. I have tried it in MATLAB 2016a and 2015b, but both have this problem. By the way, my MBD Toolbox's version is 2.0.    

#mbd toolbox for mpc5744p #.elf #matlab

9 Replies

10 Views
NXP Employee
NXP Employee

Hi lynnelee‌,

Just FYI the latest toolbox for MPC family is https://community.nxp.com/docs/DOC-342724

In your case, can you send us the Simulink Build Console log? The last lines in the console should tell us if the elf building process was successful or not

Best regards,
Daniel

0 Kudos

10 Views
Contributor II

HI, dumitru-daniel.popa,

Thank you for your reply. For some reason we have to use the MBD Toolbox 2.0 version. And following is the messages showed in my Diagnostic Viewer.

微信图片_20190711125754.png

Thank you for your help.

Kind regards,

Lynne

0 Kudos

10 Views
NXP Employee
NXP Employee

Hi lynnelee‌,

Your problem is related with the fact that MATLAB 2016a is installed in "Program Files" that contains a space. The special characters are not handle correctly by the MATLAB Embedded Coder Make File, hence it is required to try to reinstall the MATLAB in a path without any special characters and as short as possible.

Can you try that ?

Hope this will resolve your issue.

Best regards,
Daniel

0 Kudos

10 Views
Contributor II

HI dumitru-daniel.popa,

Thank you for your help. I have tried your solution but it doesn't work. T T

And the following is the new message showed on my Diagnostic Viewer.

1.png

Really need your help.

Kind regards,

Lynne

0 Kudos

10 Views
NXP Employee
NXP Employee

Hello lynnelee‌,

The problem you are facing is related to the compiler. You must use the S32 Power Architecture version 1.2  with the patch applied from this topic: https://community.nxp.com/thread/451804#comment-916493Also, please follow the Model Based Design Toolbox Installation Quick-Start guide.

What I believe is that you took the compiler from the MPC57xx version 3.0.0, and you want to use it with the MPC574xP 2.0.0 version. If you need the latest compiler please use the latest toolbox version.

Also, if this is not working, please consider sending us in text the following string in order to understand what error you are facing

pastedImage_2.png

Hope this helps,

Marius

0 Kudos

10 Views
Contributor II

Hi mariuslucianandrei‌,

Thank you for your reply.

I'm wondering if your suggestion is to install the S32 Design Studio for Power v1.2.

If so, I have tried it but it still didn't work.

And by the way, the text "系统找不到指定的路径" means that "System can not find the route".

Looking for your help.

Kind regards,

Lynne

0 Kudos

10 Views
NXP Employee
NXP Employee

Hello lynnelee‌, 

I'm wondering if your suggestion is to install the S32 Design Studio for Power v1.2.

If so, I have tried it but it still didn't work.

Yes, please use the compiler from the S32DS for Power 1.2 and set the variable S32DS_PA_TOOL in Path with the location where the v1.2 compiler is, sometthing like here:

pastedImage_4.png

And by the way, the text "系统找不到指定的路径" means that "System can not find the route".

Looking for your help.

The code generates two folders "adc_model_pnt_mbd_rtw" and "slprj". Please be sure that in the first of them you find that crt0.s file. If not, please archive the folders and attach them here.

Marius

10 Views
Contributor II

Hi mariuslucianandrei‌,

Thank you very much. My problem has been solved. 

I used S32 Design Studio for Power v1.2 with patch and reset the variable S32DS_PA_TOOL.

Kind regards,

Lynne

10 Views
Contributor II

By the way, I have also download the patch.

0 Kudos