Training Class: MQX RTOS for Kinetis SDK, Kinetis Design Studio (6 labs, including TCP/IP)

cancel
Showing results for 
Search instead for 
Did you mean: 

Training Class: MQX RTOS for Kinetis SDK, Kinetis Design Studio (6 labs, including TCP/IP)

No ratings

Training Class: MQX RTOS for Kinetis SDK, Kinetis Design Studio (6 labs, including TCP/IP)

Here is a hands-on training session for MQX RTOS with KSDK

Based on

Kinetis Design Studio (KDS) v2.0.0

Kinetis SDK v1.1.0

FRDM-K64F

The agenda for the content is:

•RTOS Theory

−Scheduling

−Tasks Communication

•MQX RTOS Basics

−Tasks

−LAB 1 – Get the Tools Working

−LAB 2 – Using Tasks

•MQX RTOS Services

−Mutex

−Semaphores

−Events

−Messages

−Interrupt Handling

−LAB 3 – Using MQX RTOS Services

•MQX RTOS for Kinetis SDK

−KSDK Architecture

−MQX Integration with KSDK

−Startup

−BSP Configuration

−Using KSDK Drivers with MQX

−Other New Features

•Ethernet Connectivity with MQX

−Initialization

−Sockets (Client-Server Model)

−LAB 4 – Client-Server

−Web Server

−LAB 5 – HTTP Server

−Ethernet Hardware

•Memory File System

•USB Stack

−Overview, Diagram, Documentation

•Using Processor Expert with MQX RTOS for KSDK

−LAB 6 – Using PEx with MQX for KSDK

•Hardware Support

−Freedom Platform

•IDE Options

−KDS

•Porting a MQX for KSDK Application

•Installation

•Evolution and Roadmap

•Support and Resources

Attachments
Comments

Congratulations ! Very good your training!

Using your guide I create e new project for a custom board using KSDK + PEx and then I add MQX like your example.

Looking the way HAL and FSL work I think is not any more necessary create a BSP. PEx take care of the hardware configuration.

Then I create tasks, RS232 for debug is Ok, interrupts GPIO when MCU is wake and for LLWU when is in STOP and everithing is working

But I note when I change my clock using:

Starts in clock #0 at 48Mhz

CLOCK_SYS_SetConfiguration(&clockMan1_InitConfig1);  // Will run in 4Mhz for Low power mode

the _time_delay()  function from MQX not work as expectec taking much more time to execute, I think because the clock #1 I´m running in lower clock.

then I call:

POWER_SYS_SetMode(1U, kPowerManagerPolicyAgreement);   // put in STOP mode LLS

And is in LLS just fine.

My question is:  How can I tell to MQX that the clock changed to calculate the _time_delay()  correctly?

Thank you

Version history
Revision #:
1 of 1
Last update:
‎05-01-2015 08:54 AM
Updated by: