Unlock and erase SNEAK32XX2

Showing results for 
Search instead for 
Did you mean: 

Unlock and erase SNEAK32XX2

Contributor II
I am yet again working with a custom board that has the processor SKEAZN32XXX2. I can connect to it but the JLink-programmer fails to read AP/DP registers when I am trying to execute the unlock Kinetis command (see "unlock kinetis command.png). 
I have tried to power off the board and then turn it on again. I am able to connect to the MCU and do the initial read upon the connect command.  But when I run the erase command I am not able to either halt the processor or erase it (see "erase command.png" for details). Also worth mentioning is that the measured VREF is 3.37V.
I have verified that the issue is not with the JLink-programmer since I have tried and successfully program and erase another custom board of ours with the same MCU.
Therefore, what causes these issues and is there any way around it?
Best regards,
Michael L..
Labels (2)
0 Kudos
2 Replies

NXP TechSupport
NXP TechSupport

Hi Michael ,

The version of SKEAZN32XXX2 is very old, would you please check if your MCU is SKEAZN32XXX2?

About the hardware circuit:
Connect 10K pullup resistor to RESET_b pin of the MCU
Connect 10K pullup resistor to NMI_b pin of the MCU

Please select Device as SKEAZN32xxx2(allow security) in JLink Commander.

Device SKEAZN32xxx2(allow security).png
Press (clear)RESET_b button and then input unlock kinetis.
Will the JLink Commander still get: Unlocking Device...ERROR: Read from DP/AP register failed! ?

Please try if you are able to flash program after input unlock kinetis.

Best Regards,



Note: If this post answers your question, please click the Correct Answer button. Thank you!

Contributor II

Hi Robin,

First, thank you for your recommendations.

On our custom boards, we do have one 10k pullup resistors on both the Reset_b pin and the NMI_b pin of the MCU.

Furthermore, I have tried to select SKEAZN32xxx2(allow security) in JLink Commander, cleared the RESET_b and then used the input unlock kinetis.

Sadly the "Unlocking Device...ERROR: Read from DP/AP register failed" still remains (See attachment for details).

Do you have more suggestions about how to solve this issue?

Edit: I found the error and solved the issue. I mixed up the reset signal with another incoming signal on one jumper on our boards which are connected to the Reset_b pin. This incoming signal drew the reset signal high while programming the MCU which makes it impossible to program the MCU. I moved the pin on the connector to where it was suppose to go according to our schematics and I am now able to program the board without any issue.

Thank you for your advice on this matter!

The issue can be closed.

Best regards,

Michael L.



0 Kudos