USB Host MSD on K22FN1M0AM12 Not Receiving Response from Attached Device

cancel
Showing results for 
Search instead for 
Did you mean: 

USB Host MSD on K22FN1M0AM12 Not Receiving Response from Attached Device

162 Views
Contributor I

I have a custom board using K22FN1M0AM12 that I am trying to implement USB Host MSD on. I am using KDS v3.2.0 with Processor Expert v3.0.2. I am not using any RTOS. I used the example "USB_MSD_HOST_K60_PEx" as a starting point. I am using the "USB_HOST_STACK" processor expert component that is also used in that example with the same configuration. 

I call the function "msd_host_init()" to initialize and get a success and then have an 8ms timer that calls the "Poll()" and "MSD_Task()" functions. When things are initialized I insert a USB stick (I have tried a few different types), and I eventually found that in the KHCI function "_usb_khci_task()" the "tick" count is reaching the defined max "KHCI_TICK_WAIT" and setting the response as NAK and never moving on. I have varied the interrupt priority for USB_LDD, changed the define "KHCI_TICK_WAIT" to a larger value, and some other things. 

I should also mention that I run the uTasker USB Host MSD bootloader on this board with success so I know the hardware is correct

Labels (1)
0 Kudos
1 Reply

46 Views
NXP TechSupport
NXP TechSupport

Hello Kevin,

 

The MCUXpresso IDE has now replaced the Kinetis Design Studio IDE as the recommended software development toolchain for NXP’s newest Kinetis, LPC and i.MX RT Cortex-M-based devices. We have usb_host_msd examples available in our MCUXpresso SDK that you can download from the link below:

Welcome | MCUXpresso SDK Builder 

Best regards,

Felipe

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos