AnsweredAssumed Answered

bugs in LPCScrypt

Question asked by Bug Reporter on Nov 16, 2016
Latest reply on Nov 21, 2016 by LPCX presso support

Just received a brand new LPC-Link2 probe and having troubles to make it work.

A utility script boot_lpcscript.cmd that supposed to program the probe itself with "LPCScrypt_140.bin.hdr" crashes.

By the way, I am running the latest release of LPCScript, but there is no version number on it - few files in the release package are labelled, but even this scarce labeling is inconsistent. Most likely the version is 1.8, but no guarantees.

 

Finally, I found that my problem was caused by a 3-d party utility dfu-util.exe called in the script.

It is not clear who built this binary, but it was probably not its developer. The latest release date on the developer site is Feb, 2016, while timestamps on the binary file and .dll that came with LPCScript is Mar, 2016.

Also, the official dfu-util.exe build Feb, 2016 does not crash on my system.

 

Conclusion:

despite multiple prior releases, LPCScript 1.8 remains unreliable and pretty much useless (for me)

Outcomes