lpcware

dfu-util is not working

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Dec 28, 2016 by Thiago Siqueira
Content originally posted in LPCWare by jchan168 on Fri Feb 05 17:59:54 MST 2016
Hi,

I am using LPCXpresso 8.0.0 and LPCXpresso54102 board on Windows 7. Everything works fine. I try to find a command line tool to flash the device over the USB port and saw this program under the bin, dfu-util. After installing the jumper JP5, it find the device ok. However, when I tried to download the image, I got the following output result as error. I tried both hex and bin file format. I appreciate any help.

c:>dfu-util -D AlgSim.bin
dfu-util 0.7

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Opening DFU capable USB device... ID 1fc9:000c
Run-time device DFU version 0100
Claiming USB DFU Runtime Interface...
Determining device status: state = dfuIDLE, status = 0
WARNING: Runtime device already in DFU state ?!?
Found Runtime: [1fc9:000c] devnum=0, cfg=1, intf=0, alt=0, name="DFU"
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 0100
Device returned transfer size 2048
No valid DFU suffix signature
Warning: File has no DFU suffix
bytes_per_hash=1221
Copying data from PC to DFU device
Starting download: [Error during download get_status

Outcomes