AnsweredAssumed Answered

How to change Yocto Rootfs (imx6ul)

Question asked by Tiago Gomes on Apr 25, 2016

Hi,

I am new to embedded Linux and have a i.MX6UL EVK board adapted to run from NAND (following these steps: https://community.freescale.com/docs/DOC-236994) and would like to know how to change the rootfs. Some settings of my system are:

MfgTool_MultiPanel (Library: 2.5.1)
mfgtool2-yocto-mx6ul-EVK-nand.vbs
rootfs_nogpu.tar.bz2
zImage, dtb and compiled modules (linux-2.6-imx-rel_imx_3.14.38_6ul_ga)
arm-linux-gnueabihf-gcc version 4.8.5 (Ubuntu / Linaro 4.8.5-1ubuntu1)

I already imagined that simply change and rename the original file rootfs_nogpu.tar.bz2 to the rootfs that I want would not work. I tried this and it did not work. Using the standard rootfs contained in MFGTOOL package (yocto), the system works normally.

After booting the kernel, the system stops with the following information:

init: ureadahead main process (56) terminated with status 5
init: mounted-proc main process (68) terminated with status 1

From this point, no more messages in the terminal.

For this test, I'm using rootfs downloaded at:
http://s3.armhf.com/dist/basefs/ubuntu-precise-12.04.4-armhf.com-20140603.tar.xz

Attached is the boot log and kernel .config

So what else should I do. Change any settings in the kernel?

Thanks!

 

Original Attachment has been moved to: Boot_LOG.txt.zip

Original Attachment has been moved to: KERNEL_CONFIG.txt.zip

Outcomes