AnsweredAssumed Answered

MPC5775k can’t connect with P&E Assistant and XTAL no dc bias

Question asked by Tan Shujie on Apr 6, 2016

Dear All, Especially Stanislav and Martin

I'm now working with MPC5775k.the EVB is SCH-27237-MPC57XXMB and SCH-27725 daughter board,

  MCU (MPC5775k) using External voltage regulation mode, the supply 12V static state power consumption at the whole board 50-60mA,Each power supply voltage conform to the requirements (power IC TPS65311Q1), However, when I connection the debugger P&E Multilink to download, get an error "the target may have entered reset escalation Please power cycle the board".

I've read page:

https://community.freescale.com/thread/386055

https://community.freescale.com/thread/386566

https://community.freescale.com/message/625762#comment-625762

https://community.freescale.com/message/627317#comment-627317

https://community.freescale.com/thread/357889#comment-530506

And try to do the corresponding operation(Changed the delay after reset time,etc), but still no avail.

 

Simplify the whole reset system is connected as shown below

Try to Disconnect the resistance R39/R45, Install the RC circuit, but still no avail.

TPS65311 power-up sequence:

crystal not only did not wave, nor DC voltage,But the demo board have DC voltage 0.46V on EXTAL and EXTAL.

I have the datasheet of MPC5775K Data Sheet_Rev6.pdf,

MPC5775K Hardware Design Guide-AN4888.pdf,

MPC5775KRM_Rev3.4.pdf,

 

Nowhere is described with respect to the timing RESET, XTAL have still not enabled?

 

Measured demo board waveform:

Power-up and downloads, the download process RESETB appear twice the low level interval 450ms, 120ms and has maintained around 110ms.

RESET_B is weak pull-up. Voltage of 2.9V, when the connector plug, voltage dropped to 2.1V, but still can not download the program. On my board the voltage dropped to 2.0V, but it does not work,

XTAL and EXTAL no clock signal and no DC bias.

I put the above components Y1 to demo board, also can work normally, Verify that components and XTAL circuit design is no problem.

So many factors that lead to A reset, resulting in a low RESETB external performance, RESETB seems to tell the outside world, "I am now in the reset state."

The reset state will lead to XTAL no DC bias, which is in the demo board be verified.

 

My question is:

1.What causes the crystal oscillator does not work ? The power-up is not wrong.

2. External voltage regulation mode, On power-up sequence RESET_B and VREG_POR_B between what is timing requirements, in the before and after the hold time?

3. How can I connect MCU successfully downloaded program?

 

Beat Regards,

tan

 

Original Attachment has been moved to: [picture]MPC5775k-can't-connect-with-P&E-Assistant-and-XTAL-no-dc-bias.zip

 

Details please see the attachment,

@Stanislav Sliva  @Martin Kovar MPC5xxx

Outcomes