AnsweredAssumed Answered

MQX RTCS HTTPSRV + Internet Explorer 11 problem

Question asked by Rafael Martinez on Feb 11, 2016
Latest reply on Feb 17, 2016 by soledad

Hi,

 

I have a web server running in a MCF52259 microprocessor with MQX Rev. 3.8. The web browser requests temperature data using a cgi script that polls the microprocessor once per second. The cgi script polling works properly when using Chrome or Firefox, but when I use Internet Explorer 11 the microprocessor can not perform other tasks for 1 second when polled by the cgi script.  Basically, the microprocessor stalls for 1 second.  I have not been able to found the problem, but I have noticed that if change the  html web page code to issue two cgi requests back-to-back (without any delay between them) the problem is solved. I have also noticed that if I change from a static public IP address (192.51.x.x) to a private IP address like 192.168.x.x or 10.x.x.x the problem is solved. Is there any MQX setup that would you recommend to change in order to solve this issue? I have changed the max_sessions from 2 to 6 but the problem was not solved. Below is my current setup. Thank for your help.

 

    _RTCSPCB_init = 4;

    _RTCSPCB_grow = 2;

    _RTCSPCB_max = 6;

    _RTCS_msgpool_init = 4;

    _RTCS_msgpool_grow = 2;

    _RTCS_msgpool_max  = 8;

    _RTCS_socket_part_init = 4;

    _RTCS_socket_part_grow = 2;

    _RTCS_socket_part_max  = 6;

 

    _RTCSTASK_stacksize = 3500;

 

    RTCS_create();

    RTCS_selectall(5000);

 

 

        // Using setup from MQX example server

        params = httpd_default_params(NULL);

        params->root_dir = (HTTPD_ROOT_DIR_STRUCT*)root_dir;

        params->index_page = "\\index.html";

        params->max_ses    = 2;

Outcomes