AnsweredAssumed Answered

i.MX6 LVDS resolution can not be dynamically adjusted correctly on Yocto 3.14.28_1.0.0

Question asked by charles huang on Dec 14, 2015
Latest reply on Dec 14, 2015 by Angelo Dureghello

u-boot command:

setenv mmcargs setenv bootargs console=${console},${baudrate} ${smp} root=${mmcroot} ${bootargs} video=mxcfb0:dev=ldb,1024x768M@60,if=RGB24 video=mxcfb1:off video=mxcfb2:off

 

LVDS resolution can not be dynamically adjusted correctly on Yocto 3.14.28_1.0.0.

But it is worked fine on Yocto 3.10.17_1.0.0.

 

Yocto 3.10.17_1.0.0 dts file:

mxcfb3: fb@2 {

  compatible = "fsl,mxc_sdc_fb";

  disp_dev = "ldb";

  interface_pix_fmt = "RGB24";

  mode_str ="800x480M@60";

  default_bpp = <16>;

  int_clk = <0>;

  late_init = <0>;

  status = "disabled";

  };

 

&ldb {

  ipu_id = <1>;

  disp_id = <0>;

  ext_ref = <1>;

  mode = "sep0";

  sec_ipu_id = <0>;

  sec_disp_id = <1>;

  status = "disabled";

};

 

Yocto 3.14.28_1.0.0 dts file:

mxcfb3: fb@2 {

  compatible = "fsl,mxc_sdc_fb";

  disp_dev = "ldb";

  interface_pix_fmt = "RGB24";

  mode_str ="800x480M@60";

  default_bpp = <16>;

  int_clk = <0>;

  late_init = <0>;

  status = "disabled";

  };

 

&ldb {

  ext_ref = "true";

  status = "okay";

 

  lvds-channel@0 {

     fsl,data-mapping = "spwg";

     fsl,data-width = <24>;

     crtc = "ipu2-di0";

     primary;

     status = "okay";

 

     display-timings {

          native-mode = <&timing0>;

          timing0: g070vw01v0 {

               clock-frequency = <29500000>;

               hactive = <800>;

               vactive = <480>;

               hback-porch = <96>;

               hfront-porch = <24>;

               vback-porch = <3>;

               vfront-porch = <10>;

               hsync-len = <72>;

               vsync-len = <7>;

          };

       };

  };

};

 

Can you tell me how to solve this issue?

 

Thank you.

 

Best Regards,

Alex Cheng

Outcomes