AnsweredAssumed Answered

Problem Securing Kinetis with MSD Bootloader

Question asked by nicholasf on Sep 8, 2015
Latest reply on Sep 10, 2015 by nicholasf

I have been using the Kinetis MSD bootloader successfully for some time, but after changing the FTFE->FSEC 'SEC' bits in the 'cfm' section definition, the program does not load successfully on to the device.  When the K60 is being programmed, Codewarrior puts up a pop-up that says "Device is secure.  Erase to unsecure?" (despite the device not being secure), and whether yes or no is selected, the Codewarrior always displays this message: "No source available for "0xFFFFFFFE (0xFFFFFFFE)()", and never gets to 'main()'.  Changing other bits in the cfm section does not cause the same problem.  There are some threads on this forum which describe very similar problems, but none seem to solve the problem (in this case).  I have tried using Codewarrior with a PE Micro JTAG debugger, and using a Segger production JTAG programmer, with exactly the same result. 

 

Here are some of the resources I have found most relevant to the issue:

Setting Kinetis L Security with Codewarrior

Preventing Reverse Engineering: Enabling Flash Security | MCU on Eclipse

K60F120 No source available for "0xFFFFFFFE (0xFFFFFFFE)() "

 

http://cache.freescale.com/files/microcontrollers/doc/app_note/AN4379.pdf

http://cache.freescale.com/files/microcontrollers/doc/app_note/AN4507.pdf

 

Thanks for your time and attention.

 

edit:  I have been doing further testing, and Codewarrior is no longer giving the "secure" message, but the device is still crashing before getting to main.

Outcomes