i.MX RT1050 - cannot flash download

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX RT1050 - cannot flash download

602 Views
rodbell
Contributor I

Hello NXP Community,

I've just bought a i.MX RT1050 EV kit from Farnell and have spent the last few days getting to understand some of the design tools. I've installed the MCUXpresso IDE, the SDK, Keil uVision and IAR plus Embedded Wizard. I was starting to get somewhere and had a demo GUI application (shapes and sliders) working on the touch screen.

I then compiled another demo (Paper Cutter) from the Embedded Wizard collection and that created a bin file successfully following this tutorial Platform Integration and Build Environments: Getting started with i.MX RT1050

I tried various combinations of the SW7 switch to try and program the bin file to my board (which did appear under the File Manager as D drive); but nothing seemed to work.

Now when I try out some of the previous examples that did work I find I can compile the code using the different IDEs but all of them seem to fail during the flash programming. Is it possible that I have overwritten something in the boot RAM of the board? Using uVision I now get errors like this whilst trying to download the ecompass demo (which worked yesterday).

pastedImage_2.png

pastedImage_3.png

I'd be really grateful if someone can explain what I may have done and how to reset the i.MX board's memory as to the factory settings.

Thank you.

Rod

Labels (1)
2 Replies

227 Views
jay_heng
NXP Employee
NXP Employee

You can also try this tool, with this tool, You can flash bare image into various boot devices easily and don't need to care about headers (ivt, boot data...)

GitHub - JayHeng/nxp-sec-boot-ui: A one-stop GUI tool to work with NXP MCU (Kinetis, i.MXRT, LPC) RO... 

0 Kudos

227 Views
CarlosCasillas
NXP Employee
NXP Employee

Hi Rod,

You could try the “Troubleshooting” section of the document included on the following Community link:

https://community.nxp.com/community/mcuxpresso/mcuxpresso-ide/blog/2017/12/07/overview-of-using-the-...

 
Hope this will be useful for you.
Best regards!
/Carlos

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------