Imx53 yocto with 2.6.35 Kernel

cancel
Showing results for 
Search instead for 
Did you mean: 

Imx53 yocto with 2.6.35 Kernel

Jump to solution
827 Views
kravik
Contributor IV

Hi,

I have I.MX53 EVK board(MCIMX535DVV1C). I want to use Yocto build system with 2.6.35 Kernel.

Can you please provide the link to download Yocto for I.MX53 Evk(MCIMX535DVV1C).

Thanks in advance.

Labels (2)
Tags (2)
0 Kudos
1 Solution
93 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hi Ravi,

Please check the latest release notes for Yocto comunnity BSP, For i.MX53QSB kernel 2.6.35-3 version is the default kernel provided.

FSL Community BSP Release Notes 1.8 documentation

In order to download the BSP source code please check:

FSL Community BSP

Regards

View solution in original post

3 Replies
94 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hi Ravi,

Please check the latest release notes for Yocto comunnity BSP, For i.MX53QSB kernel 2.6.35-3 version is the default kernel provided.

FSL Community BSP Release Notes 1.8 documentation

In order to download the BSP source code please check:

FSL Community BSP

Regards

View solution in original post

93 Views
kravik
Contributor IV

Hi Bio,

Thanks for the info, I have downloaded BSP as per the steps at http://freescale.github.io/#download and executed following commands.

ubuntu-OptiPlex-7010:~/fsl-community-bsp/build$MACHINE=imx53qsb

ubuntu-OptiPlex-7010:~/fsl-community-bsp/build$source setup-environment build

ubuntu-OptiPlex-7010:~/fsl-community-bsp/build$bitbake core-image-minimal

Initially I got the following error, but issue solved after installing libsdl using "sudo apt-get install libsdl1.2-dev"

----------------------------------------------------------------------------------------------------------------------------------------------------------

WARNING: Host distribution "Ubuntu-12.04" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.

ERROR:  OE-core's config sanity checker detected a potential misconfiguration.

    Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).

    Following is the list of potential problems / advisories:

    libsdl-native is set to be ASSUME_PROVIDED but sdl-config can't be found in PATH. Please either install it, or configure qemu not to require sdl.

----------------------------------------------------------------------------------------------------------------------------------------------------------

Now I am getting checksum error for gcc-4.9.2

-----------------------------------------------------------------------------------------------------------------------------------------------------------

WARNING: Checksum failure encountered with download of http://ftp.gnu.org/gnu/gcc/gcc-4.9.2/gcc-4.9.2.tar.bz2 - will attempt other sources if available

WARNING: Renaming /home/ubuntu/IMX53_evk/fsl-community-bsp/downloads/gcc-4.9.2.tar.bz2 to /home/ubuntu/IMX53_evk/fsl-community-bsp/downloads/gcc-4.9.2.tar.bz2_bad-checksum_cd0555f00a1309a03c7447044a7dfb62

ERROR: Checksum failure fetching http://ftp.gnu.org/gnu/gcc/gcc-4.9.2/gcc-4.9.2.tar.bz2

ERROR: Function failed: Fetcher failure for URL: 'http://ftp.gnu.org/gnu/gcc/gcc-4.9.2/gcc-4.9.2.tar.bz2'. Checksum mismatch!

File: '/home/ubuntu/IMX53_evk/fsl-community-bsp/downloads/gcc-4.9.2.tar.bz2' has md5 checksum 4149e7f41fe7d626bce5869575774436 when 4df8ee253b7f3863ad0b86359cd39c43 was expected

File: '/home/ubuntu/IMX53_evk/fsl-community-bsp/downloads/gcc-4.9.2.tar.bz2' has sha256 checksum 70b590407cdfc4ddde171e10ce78d0d53398ec84a1a83a369fd3e40d35b0400c when 2020c98295856aa13fda0f2f3a4794490757fc24bcca918d52cc8b4917b972dd was expected

If this change is expected (e.g. you have upgraded to a new version without updating the checksums) then you can use these lines within the recipe:

SRC_URI[md5sum] = "4149e7f41fe7d626bce5869575774436"

SRC_URI[sha256sum] = "70b590407cdfc4ddde171e10ce78d0d53398ec84a1a83a369fd3e40d35b0400c"

Otherwise you should retry the download and/or check with upstream to determine if the file has become corrupted or otherwise unexpectedly modified.

ERROR: Logfile of failure stored in: /home/ubuntu/IMX53_evk/fsl-community-bsp/build/tmp/work-shared/gcc-4.9.2-r0/temp/log.do_fetch.31161

ERROR: Task 956 (/home/ubuntu/IMX53_evk/fsl-community-bsp/sources/poky/meta/recipes-devtools/gcc/gcc-source_4.9.bb, do_fetch) failed with exit code '1'

-------------------------------------------------------------------------------------------------------------------------------------------------------------

In poky/meta/recipes-devtools/gcc/gcc-4.9.inc file the checksum value is updated as shown below.

SRC_URI[md5sum] = "4df8ee253b7f3863ad0b86359cd39c43"

Do I need to try with different GNU_MIRROR or checksum. Can you please guide to fix this issue.

0 Kudos
93 Views
kravik
Contributor IV

It is working fine when I use direct line.

In office network few of the URLs are blocked, so may be while trying with mirrors it is giving checksum mismatch issue.

0 Kudos