How to enable multi-core for i.MX6 dual.

cancel
Showing results for 
Search instead for 
Did you mean: 

How to enable multi-core for i.MX6 dual.

Jump to solution
1,039 Views
trongthinh
Contributor IV

Hi all,

I found that only one CPU online on my i.MX6 Dual. 

processor : 0
model name : ARMv7 Processor rev 10 (v7l)
BogoMIPS : 3.00
Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpd32
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x2
CPU part : 0xc09
CPU revision : 10

Hardware : Freescale i.MX6 Quad/DualLite (Device Tree)
Revision : 0000
Serial : 0000000000000000

This is the kernel source that i use. I didn't modify any file in source code. My device tree include imx6q.dtsi which includes 4 CPUs declaration insight.

https://github.com/Freescale/linux-fslc.git

Can any one give advice? Any suggest is welcome.

Thank all.
Labels (3)
Tags (2)
1 Solution
417 Views
trongthinh
Contributor IV

Hi Carlos,

I am sure that maxcpus arg is not set in my u-boot environment. Therefore, I tried to set maxcpus=2 in boot arg and i found that 2 CPU were online. Why I need to set this bootarg? i.MX6q/i.MX6D are multi-core, I suggest this bootarg should be default.

View solution in original post

0 Kudos
5 Replies
417 Views
Carlos_Musich
NXP Employee
NXP Employee

Hi,

- Can you share the full part number of the device you are using?

- What MACHINE did you use when you built Linux image?

- Can you share the output of cat /proc/cpuinfo?

- Note that in uboot you can modify the number of cpus that will be enabled at boot time, you can change this in bootargs with variable max_cpus. If this variable is not set then the default is all the available cpus.

Regards,

Carlos

0 Kudos
417 Views
trongthinh
Contributor IV

Hi Carlos,

- This is full part number

MCIMX6D7CVT08AD

- This is the MACHINE I used

meta-freescale, branch morty lasted commit, MACHINE = imx6qsabresd.conf.

note: I created my custom machine, but I simply copy and rename the file above.

- This is all content of /proc/cpuinfo

processor : 0
model name : ARMv7 Processor rev 10 (v7l)
BogoMIPS : 3.00
Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpd32
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x2
CPU part : 0xc09
CPU revision : 10

Hardware : Freescale i.MX6 Quad/DualLite (Device Tree)
Revision : 0000
Serial : 0000000000000000

- I did not set variable max_cpus in u-boot env.

Best Regards,

Thinh

0 Kudos
417 Views
Carlos_Musich
NXP Employee
NXP Employee

Hi Thinh,

If you are sure that bootargs are not set to use only one CPU the it looks like hardware issue. Did you burned the fuses?

0 Kudos
418 Views
trongthinh
Contributor IV

Hi Carlos,

I am sure that maxcpus arg is not set in my u-boot environment. Therefore, I tried to set maxcpus=2 in boot arg and i found that 2 CPU were online. Why I need to set this bootarg? i.MX6q/i.MX6D are multi-core, I suggest this bootarg should be default.

View solution in original post

0 Kudos
417 Views
Carlos_Musich
NXP Employee
NXP Employee

I agree, I will check that.