Can't get started with yocto...

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't get started with yocto...

8,037 Views
Senior Contributor II

I've been working with custom iMX6 hardware that is similar to the SabreSDB eval board.

My host development machine started off as UBUNTU 12.04 LTS Desktop.

Up to this point I've been working with u-boot-2013.10 and linux-3.12 with buildroot to create rootfs.

Referring to a few other threads:

command line doesn't process wildcards, why?

Any examples on how to modify the .dts (device tree) source for custom hardware?

I've hit some snags that tell me I should back off on my kernel. 

So I decided to check out the yocto stuff.

I started with...

Freescale Yocto Project main page

and installed the needed packages.  Then referred to the instructions..

https://github.com/Freescale/fsl-community-bsp-platform/blob/dylan/README

to get started.  I didn't get far :-(

Initially the line

repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b dylan

returned the error: fatal: git 1.7.2 or later required.  Running 'git --version' returned 1.6.3,

and 'sudo apt-get install git-core' said I had the latest.  So I pulled down git 1.8.3 tarball from

kernel.org and installed that.

Now the line

repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b dylan

returns with the error message:  

fatal: Cannot get https://gerrit.googlesource.com/git-repo/clone.bundle

fatal: HTTP error 400

and sure enough if I use my browser to go to that site, it returns "Not found".

Any clue what I'm doing wrong? 

Labels (3)
13 Replies

33 Views
Specialist I

Ed,

Please take a look at these instructions

https://github.com/Freescale/fsl-community-bsp-platform/blob/dora/README

Dora is the latest stable release, dylan was the last.

Correct the curl's link so you can get the repo script, the run the repo with -b dora.

I have corrected the community document (the link to a dylan README). You indirectly pointed out the problem. Thanks

Leo

0 Kudos

33 Views
Senior Contributor II

Leo,

I must be doing something stupid.

Not sure what you mean by "Correct the curl's link so you can get the repo script".

The 'curl' line above seems to do what its supposed to do (it retrieves a repo script).

Its the repo line (see above) that's messing up.

Regardless of whether I use -b dylan or -b dora, I get the same result...

$ repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b dora

fatal: Cannot get https://gerrit.googlesource.com/git-repo/clone.bundle

fatal: HTTP error 400

$

What am I missing here?

Ed

0 Kudos

33 Views
Specialist I

Sorry Ed, somehow I though you have problem fetching the repo script.

I am not getting the error you found. What is the version of the repo? You should be using this

$ repo --version
repo version v1.12.7
       (from https://gerrit.googlesource.com/git-repo)
repo launcher version 1.20
       (from /home/leo/bin/repo)
git version 1.8.4.4
Python 2.7.3 (default, Sep 26 2013, 20:03:06)
[GCC 4.6.3]

0 Kudos

33 Views
Senior Contributor II

Leo,

I'm using the version of repo that is pulled down by the 'curl' command...


curl http://commondatastorage.googleapis.com/git-repo-downloads/repo > ~/bin/repo


What version of UBUNTU are you running?  I started with 12.04 LTS Desktop; but obviously

have made updates since then.  I did all the pre-installs as outlined on the YOCTO page,

so I'm baffled now...

0 Kudos

33 Views
Specialist I

Actually, I see the same error that you, but repo continues to work. Do you have some alias with curl? I am using the same OS that you, and repo should be OS agnostic....

Can you try in other machine? are you behind a proxy?

$ export REPO_CURL_VERBOSE=1

$ repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b dora

send: 'GET /git-repo/clone.bundle HTTP/1.1\r\nAccept-Encoding: identity\r\nHost: gerrit.googlesource.com\r\nConnection: close\r\nUser-Agent: Python-urllib/2.7\r\n\r\n'

reply: 'HTTP/1.1 404 Not Found\r\n'

header: Expires: Fri, 01 Jan 1990 00:00:00 GMT

header: Pragma: no-cache

header: Cache-Control: no-cache, no-store, max-age=0, must-revalidate

header: Date: Thu, 23 Jan 2014 18:05:02 GMT

header: Content-Type: text/plain; charset=UTF-8

header: Content-Length: 10

header: X-Content-Type-Options: nosniff

header: X-Frame-Options: SAMEORIGIN

header: X-XSS-Protection: 1; mode=block

header: Server: GSE

header: Alternate-Protocol: 443:quic

header: Connection: close

Get https://gerrit.googlesource.com/git-repo

remote: Counting objects: 108, done

remote: Finding sources: 100% (108/108)

remote: Total 2692 (delta 1497), reused 2692 (delta 1497)

Receiving objects: 100% (2692/2692), 1.98 MiB | 692.00 KiB/s, done.

Resolving deltas: 100% (1497/1497), done.

From https://gerrit.googlesource.com/git-repo

* [new branch]      maint      -> origin/maint

* [new branch]      master     -> origin/master

* [new branch]      stable     -> origin/stable

* [new tag]         v1.0       -> v1.0

* [new tag]         v1.0.1     -> v1.0.1

* [new tag]         v1.0.2     -> v1.0.2

* [new tag]         v1.0.3     -> v1.0.3

* [new tag]         v1.0.4     -> v1.0.4

* [new tag]         v1.0.5     -> v1.0.5

* [new tag]         v1.0.6     -> v1.0.6

* [new tag]         v1.0.7     -> v1.0.7

* [new tag]         v1.0.8     -> v1.0.8

* [new tag]         v1.0.9     -> v1.0.9

* [new tag]         v1.1       -> v1.1

* [new tag]         v1.10.0    -> v1.10.0

* [new tag]         v1.10.1    -> v1.10.1

* [new tag]         v1.10.2    -> v1.10.2

* [new tag]         v1.10.3    -> v1.10.3

* [new tag]         v1.10.4    -> v1.10.4

* [new tag]         v1.11.0    -> v1.11.0

* [new tag]         v1.11.1    -> v1.11.1

* [new tag]         v1.12.0    -> v1.12.0

* [new tag]         v1.12.1    -> v1.12.1

* [new tag]         v1.12.2    -> v1.12.2

* [new tag]         v1.12.3    -> v1.12.3

* [new tag]         v1.12.3.1  -> v1.12.3.1

* [new tag]         v1.12.4    -> v1.12.4

* [new tag]         v1.12.5    -> v1.12.5

* [new tag]         v1.12.6    -> v1.12.6

* [new tag]         v1.12.7    -> v1.12.7

* [new tag]         v1.2       -> v1.2

* [new tag]         v1.3       -> v1.3

* [new tag]         v1.3.1     -> v1.3.1

* [new tag]         v1.3.2     -> v1.3.2

* [new tag]         v1.4       -> v1.4

* [new tag]         v1.4.1     -> v1.4.1

* [new tag]         v1.4.2     -> v1.4.2

* [new tag]         v1.4.3     -> v1.4.3

* [new tag]         v1.4.4     -> v1.4.4

* [new tag]         v1.5       -> v1.5

* [new tag]         v1.5.1     -> v1.5.1

* [new tag]         v1.6       -> v1.6

* [new tag]         v1.6.1     -> v1.6.1

* [new tag]         v1.6.10    -> v1.6.10

* [new tag]         v1.6.10.1  -> v1.6.10.1

* [new tag]         v1.6.10.2  -> v1.6.10.2

* [new tag]         v1.6.2     -> v1.6.2

* [new tag]         v1.6.3     -> v1.6.3

* [new tag]         v1.6.4     -> v1.6.4

* [new tag]         v1.6.5     -> v1.6.5

* [new tag]         v1.6.6     -> v1.6.6

* [new tag]         v1.6.7     -> v1.6.7

* [new tag]         v1.6.7.1   -> v1.6.7.1

* [new tag]         v1.6.7.2   -> v1.6.7.2

* [new tag]         v1.6.7.3   -> v1.6.7.3

* [new tag]         v1.6.7.4   -> v1.6.7.4

* [new tag]         v1.6.7.5   -> v1.6.7.5

* [new tag]         v1.6.8     -> v1.6.8

* [new tag]         v1.6.8.1   -> v1.6.8.1

* [new tag]         v1.6.8.10  -> v1.6.8.10

* [new tag]         v1.6.8.11  -> v1.6.8.11

* [new tag]         v1.6.8.2   -> v1.6.8.2

* [new tag]         v1.6.8.3   -> v1.6.8.3

* [new tag]         v1.6.8.4   -> v1.6.8.4

* [new tag]         v1.6.8.5   -> v1.6.8.5

* [new tag]         v1.6.8.6   -> v1.6.8.6

* [new tag]         v1.6.8.7   -> v1.6.8.7

* [new tag]         v1.6.8.8   -> v1.6.8.8

* [new tag]         v1.6.8.9   -> v1.6.8.9

* [new tag]         v1.6.9     -> v1.6.9

* [new tag]         v1.6.9.1   -> v1.6.9.1

* [new tag]         v1.6.9.2   -> v1.6.9.2

* [new tag]         v1.6.9.3   -> v1.6.9.3

* [new tag]         v1.6.9.4   -> v1.6.9.4

* [new tag]         v1.6.9.5   -> v1.6.9.5

* [new tag]         v1.6.9.6   -> v1.6.9.6

* [new tag]         v1.6.9.7   -> v1.6.9.7

* [new tag]         v1.6.9.8   -> v1.6.9.8

* [new tag]         v1.7       -> v1.7

* [new tag]         v1.7.1     -> v1.7.1

* [new tag]         v1.7.2     -> v1.7.2

* [new tag]         v1.7.3     -> v1.7.3

* [new tag]         v1.7.3.1   -> v1.7.3.1

* [new tag]         v1.7.4     -> v1.7.4

* [new tag]         v1.7.4.1   -> v1.7.4.1

* [new tag]         v1.7.4.2   -> v1.7.4.2

* [new tag]         v1.7.4.3   -> v1.7.4.3

* [new tag]         v1.7.5     -> v1.7.5

* [new tag]         v1.7.6     -> v1.7.6

* [new tag]         v1.7.6.1   -> v1.7.6.1

* [new tag]         v1.7.7     -> v1.7.7

* [new tag]         v1.7.7.1   -> v1.7.7.1

* [new tag]         v1.7.7.2   -> v1.7.7.2

* [new tag]         v1.7.7.3   -> v1.7.7.3

* [new tag]         v1.7.7.4   -> v1.7.7.4

* [new tag]         v1.7.7.5   -> v1.7.7.5

* [new tag]         v1.7.7.6   -> v1.7.7.6

* [new tag]         v1.7.8     -> v1.7.8

* [new tag]         v1.7.8.1   -> v1.7.8.1

* [new tag]         v1.7.8.2   -> v1.7.8.2

* [new tag]         v1.8.0     -> v1.8.0

* [new tag]         v1.8.1     -> v1.8.1

* [new tag]         v1.8.2     -> v1.8.2

* [new tag]         v1.9.0     -> v1.9.0

* [new tag]         v1.9.1     -> v1.9.1

* [new tag]         v1.9.2     -> v1.9.2

* [new tag]         v1.9.3     -> v1.9.3

* [new tag]         v1.9.4     -> v1.9.4

* [new tag]         v1.9.5     -> v1.9.5

* [new tag]         v1.9.6     -> v1.9.6

Get https://github.com/Freescale/fsl-community-bsp-platform

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current

                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0

curl: (22) The requested URL returned error: 404

Server does not provide clone.bundle; ignoring.

remote: Reusing existing pack: 147, done.

remote: Total 147 (delta 0), reused 0 (delta 0)

Receiving objects: 100% (147/147), 21.69 KiB | 0 bytes/s, done.

Resolving deltas: 100% (47/47), done.

From https://github.com/Freescale/fsl-community-bsp-platform

* [new branch]      danny      -> origin/danny

* [new branch]      denzil     -> origin/denzil

* [new branch]      dora       -> origin/dora

* [new branch]      dylan      -> origin/dylan

* [new branch]      master     -> origin/master

* [new branch]      master-next -> origin/master-next

* [new tag]         1.2        -> 1.2

* [new tag]         1.4        -> 1.4

* [new tag]         1.5        -> 1.5

Your identity is: Leonardo Sandoval <leo@freescale.com>

If you want to change this, please re-run 'repo init' with --config-name

repo has been initialized in /home/b42214/fsl/yocto/tmp

b42214@vfae-server:~/fsl/yocto/tmp$

0 Kudos

33 Views
Senior Contributor II

I don't get it..

Here it my output...

$ export REPO_CURL_VERBOSE=1

$ repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b dora 2>&1 | tee repo.out

fatal: Cannot get https://gerrit.googlesource.com/git-repo/clone.bundle

fatal: HTTP error 400

send: 'GET https://gerrit.googlesource.com/git-repo/clone.bundle HTTP/1.1\r\nAccept-Encoding: identity\r\nHost: gerrit.googlesource.com\r\nConnection: close\r\n

User-Agent: Python-urllib/2.6\r\n\r\n'

reply: 'HTTP/1.1 400 Bad Request\r\n'

header: Cache-Control: no-cache

header: Pragma: no-cache

header: Content-Type: text/html; charset=utf-8

header: Proxy-Connection: close

header: Connection: close

header: Content-Length: 681

Notice that your http reply is "not found", but mine is "bad request".

Yes, I am behind a proxy, but other tools like wget & curl work just fine.

Also, I can't tell you the version of repo because...

$ repo --version

error: repo is not installed.  Use "repo init" to install it here.

Note that it was put in my bin by curl and the path is set correctly, but its telling me its not installed.

That makes absolutely no sense.  If its not installed, then how can I run "repo init" to install it?

By the way what version of python are you running with?  I have 2.6.2, and according to apt-get I have the latest.

0 Kudos

33 Views
Specialist I

No idea. Post your problem to the mailing list meta-freescale.

One last suggestion.... what is the output of `which repo`? make sure you PATH has the directory where repo was stored and it has execution permission (export PATH=$PATH:$HOME/bin; chmod +x $HOME/bin/repo, in case repo is on $HOME/bin)

0 Kudos

33 Views
Senior Contributor II

Yep, I checked all that stuff...

$ which repo

/home/els/bin/repo

$ ls -l /home/els/bin/repo

-rwxr-xr-x 1 els els 23618 2014-01-23 14:17 /home/els/bin/repo

What's your version of python?

Meanwhile, I'm just gonna try to pull down the kernel with git.

I have uboot from mainline and I build rootfs with buildroot so I really only need the kernel.

Thanks,

0 Kudos

33 Views
Specialist I

$ curl --version
curl 7.22.0 (x86_64-pc-linux-gnu) libcurl/7.22.0 OpenSSL/1.0.1 zlib/1.2.3.4 libidn/1.23 librtmp/2.3
Protocols: dict file ftp ftps gopher http https imap imaps ldap pop3 pop3s rtmp rtsp smtp smtps telnet tftp
Features: GSS-Negotiate IDN IPv6 Largefile NTLM NTLM_WB SSL libz TLS-SRP

$ python --version
Python 2.7.3

Can you run the command using strace?

$ set -x; strace repo -u .... -b

Verbosity at most but with your issue the more the better.

0 Kudos

33 Views
Senior Contributor II

Interesting, for both tools I have older versions; however apt-get says I'm up-to-date...

$ curl --version

curl 7.18.2 (i486-pc-linux-gnu) libcurl/7.18.2 OpenSSL/0.9.8g zlib/1.2.3.3 libidn/1.10

Protocols: tftp ftp telnet dict ldap ldaps http file https ftps

Features: GSS-Negotiate IDN IPv6 Largefile NTLM SSL libz

$ python --version

Python 2.6.2

$ sudo apt-get install curl python

[sudo] password for els:

Reading package lists... Done

Building dependency tree

Reading state information... Done

curl is already the newest version.

python is already the newest version.

python set to manually installed.

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

0 Kudos

33 Views
Senior Contributor IV

Ed

Had your issue got resolved? If yes, we are going to close the discussion in 3 days. If you still need help please feel

free to contact Freescale.

Thanks,
Yixing

0 Kudos

33 Views
Senior Contributor II

Yixing,

Again, not resolved, but you can close this if you want to.

I gave up on YOCTO and just use git.freescale for the kernel, denx uboot and buildroot for rootfs.

Ed

33 Views
Senior Contributor IV

Ed

I marked the discussion as assumed answered. If you have any furthe questions late, please feel free to come here again by create a new discussion or reopen this one.

Regards,

Yixing

0 Kudos