PF8121 : TBB with FlexGUI (No Vendor ID/ Product ID)

cancel
Showing results for 
Search instead for 
Did you mean: 

PF8121 : TBB with FlexGUI (No Vendor ID/ Product ID)

321 Views
Contributor II

Platform: i.MX 8M-Mini + PF8121

Hi jinyuzhang,

I'm using the KITPF8121FRDMEVM to evaluate TBB mode on PF8121 PMIC for a future design using IMX8M Mini with PF8121 F2. I am following the design guide which mentions:

"When the FlexGUI is done loading, the USB-HID connection will automatically search for the KITPF8121FRDMEVM, if a valid board is connected, the corresponding Vendor ID and Product ID should appear, then click Start to create a connection."

I see a valid USB-HID connection but do not see a Vendor and product ID in the FlexGUI. 

pastedImage_5.png

Also when I open Flex Gui to select the correct kit ', I do not see a checkbox for B0/Release. Advanced settings only has 'production' in its drop down menu. 

pastedImage_4.png


Thanks,
Juhi

0 Kudos
6 Replies

91 Views
NXP Employee
NXP Employee

Hi, Juhi

Did the silicon sample in you hand is B0? Pls. try to select PF8200 in checkbox of FlexGUI launcher as below picture showed. 

pastedImage_1.png

0 Kudos

91 Views
Contributor II

Thanks for the reply Dennis. The PMIC part number on this evaluation kit is MC32- PF8121- A0- EP- XAALLC).

Selecting PF8200 also didn't help. Flex GUI still does not give vendor ID.

pastedImage_1.png

Can you help debug this further?

Best,

Juhi

0 Kudos

91 Views
NXP Employee
NXP Employee

Hi Juhi

    I think your operation is right when select PF8121 ,however you still can't connect the board.

    https://www.nxp.com/docs/en/user-guide/UM11214.pdf 

    Here is a user guide of the board and you can check detial.

     the first thing you should check is :

     (1) Whether need to update the flash and firmware driver?

     (2) When USB connect ,whether there is right device found in device managment of PC

     (3) Make sure the Jumper are right place 

     (4) VIn should be the connected with SWIN at any time.

    Anyway ,if you follow the user guide and still can't find it work, we will consider weather there is demage of Device

BRs

jinyu   

91 Views
Contributor II

Thanks Jinyu, 

Thanks fr your suggestion. My problem was with an old boot loader version which did not support Windows 10. I fixed that issue and see the vendor ID now. 

Now my next issue is with the TBB script I'm trying to use with the GUI. See this:

pastedImage_2.png

0 Kudos

91 Views
Contributor II

https://community.nxp.com/message/1211981?commentID=1211981&et=watches.email.thread#comment-1211981

This is the script I'm using. As suggested by Jose I disabled OTP_LDO1_SEQ and OTP_LDO2_SEQ.

Please provide your feedback.

Thanks,

Juhi

0 Kudos

91 Views
Contributor II

Hi Jinyu,

My main issue was with the KL25Z Firmware. I updated the bootloader version and that fixed my problem.

 

After that I was able to verify TBB configuration using script on the evaluation board. 

 

Thanks for your support.

-Juhi

0 Kudos