Redlink server unable to connect to core

cancel
Showing results for 
Search instead for 
Did you mean: 

Redlink server unable to connect to core

1,468 Views
Contributor II

 FRDM-KL82Z on the MCUXpressoIDE  

After working a while an error appeared during a debug session reporting that it was impossible to stop the debug session, I pressed both stop buttons and it seemed all alright but when I tried to debug again and this error kept appearing every time I try it:

  --------------------------------------------------------------------------------------------------------------------------------------  

Ns: MCUXpresso RedlinkMulti Driver v10.0 (Jun 22 2017 23:31:55 - crt_emu_cm_redlink.exe build 272)  Pc: ( 0) Reading remote configuration  Wc(03). No cache support.  Pc: ( 5) Remote configuration complete  Nc: Reconnected to existing redlink server (PID 4294967295)  Nc: Connecting to probe 1 core 0 (server PID unknown) gave 'Ee(36). Could not connect to core.'  Nc: Connecting to probe 1 core 0 (server PID unknown) gave 'Ee(36). Could not connect to core.'  Nc: Connecting to probe 1 core 0 (server PID unknown) gave 'Ee(36). Could not connect to core.'  Nc: Server OK but no connection to probe 1 core 0 (after 3 attempts) - Ee(36). Could not connect to core.  Ed:02: Failed on connect: Ee(36). Could not connect to core.  Et:31: No connection to chip's debug port  Pc: (100) Target Connection Failed  Nc: error closing down debug session - Em(02). MEM-AP is not selected.  

-------------------------------------------------------------------------------------------------------------------------------------------    

I also tried to use other debuggers and to do a mass erase but it reports the same error.   The board is connected via USB using the SWD option.    Thank you very much.

I checked some information on the community but I havent been able to solve my problem:

https://community.nxp.com/thread/456134 

I want to remark that I've been able to debug with the board for 2 weeks tils this happened.

I thought it could be a problem of the board so I switched to another FRDM KL82Z board that I have and I've been able to debug 1 time before appearing the same error.

I also uninstalled MCUXpresso IDE and installed it again and the error persisted, I have no red link process on the background and I tried diferent USB ports and cables and also powering the board through the two USB inputs available.

Labels (1)
0 Kudos
2 Replies

105 Views
NXP Employee
NXP Employee

I presume that you are using the built in OpenSDA debug probe on your FRDM-KL82Z ?

Anyway, please can you follow the below steps ....

First of all  ensure that the IDE is not running, and check that in Task Manager (or similar, depending on your host OS) that you have now spurious tasks running with names of the form :

  • redlinkserv
  • arm-none-eabi_gdb*
  • crt_emu_*

[ Aside : you might want to check out section 14.12 of the MCUXpresso IDE v10.0.2 User Guide, in particular 14.12.7 "Troubleshooting LPC-Link2". Although focused on the LPC-Link2 debug probe, much of the information can be applied to other CMSIS-DAP probes - like the OpenSDA "DAPLink". ]

Now start the IDE back up again. I presume you have a project in your workspace for KL82, but if not import one of the demo apps from the SDK.

Now delete any .launch files that exist within your project as viewed in the Project Explorer view (i.e. the debug launch configuration files).

Now go to the Quickstart Panel view, and click on the "Debug button". The IDE should go through the probe discovery sequence, spotting your OpenSDA probe, generate an appropriate launch configuration, and start a debug session.

Does this now work for you? If not, please post the text from debug log (how to do this is described in section 14.11, "The Console View", of the MCUXpresso IDE v10.0.2 User Guide.

Also, I would recommend that make sure that your FRDM-KL82Z board has the latest "DAPLink" firmware installed in the onboard debug probe which you can find at : http://www.nxp.com/OpenSDA

 

Regards,

MCUXpresso IDE Support.

0 Kudos

105 Views
Contributor II

Hi thank you for your fast answer, I already did those steps following other posts solutions but it didn't worked.

After a while I achieved to do a mass erase of the flash memory following this steps:

1.Prepare the flash manager tool on MCUXpresso to do a mass erase

2.Pres the reset button on your FRDM KL-82Z BOARD

3. Press the OK button so the flash tool can start the mass erase

4. Release the reset button before the process starts

This worked for me on both boards, on the second one I had to repeat the process a couple of times because you have to be very precise on timing when releasing the reset button.

Now I'm able to work normally with both boards.

0 Kudos