Adding CMSIS-DSP Library to a KSDK 2.x project in Kinetis Design Studio

Showing results for 
Search instead for 
Did you mean: 

Adding CMSIS-DSP Library to a KSDK 2.x project in Kinetis Design Studio

No ratings

Adding CMSIS-DSP Library to a KSDK 2.x project in Kinetis Design Studio

Hello community!


This document explains how to link the CMSIS-DSP library to a KSDK 2.x project in KDS.


The steps described in the document were done using the MK64FN1M0VLL12 MCU like the one in the FRDM-K64F board, but the same principles are applicable to any Kinetis MCU.



Software versions

The steps described in this document are valid for the following versions of the software tools:

  • KDS v3.2.0
  • KSDK v2.x





1. Glossary.

2. Overview and concepts.

     2.1 CMSIS - Cortex Microcontroller Software Interface Standard.

          2.1.1 CMSIS Components.

3. DSP example application.

     3.1 Creating KSDK 2.x Project.

     3.2 Linking CMSIS-DSP Library.

     3.2 Importing DSP example source files.

Appendix A - References.



I hope you can benefit from this post, if you have questions please let me know.


Best Regards!

Carlos Mendoza

Labels (1)

I have been trying to link the CMSIS DSP lib to my MK24F project in KDS version 3.0. I am using KSDK version 1.3.0.

I was so glad to have found the instruction provided here. It looked like it should have worked. However, I still have the same error

after implemented the steps provided in the pdf file.

c:/freescale/kds_v3/toolchain/bin/../lib/gcc/arm-none-eabi/4.8.4/../../../../arm-none-eabi/bin/ld.exe: cannot find -llibarm_cortexM4lf_math.a

collect2.exe: error: ld returned 1 exit status

makefile:116: recipe for target 'mk24f.elf' failed

make: *** [mk24f.elf] Error 1

I checked the make sure I was using the '/' instead of the '\' and pasted the path in the file explorer to verify that it was correct.

Any idea why the ld.exe was not able to find the lib file?

Thank you,


Hi Ron,

The same steps apply with a KSDK 1.3 project. Please make sure that you use the library name "arm_cortexM4lf_math", the name should not include the ‘lib’ prefix and ‘.a’ suffix:


Hope it helps!

Best Regards,
Carlos Mendoza
Technical Support Engineer

Version history
Revision #:
1 of 1
Last update:
‎07-13-2016 04:57 PM
Updated by: