AnsweredAssumed Answered

Problem on reprogram MC56F8006 if the unused I/O pins are initialized

Question asked by janio gabriel on Aug 5, 2010
Latest reply on Sep 27, 2010 by Willie Wei

Hello!

 

I was working with my project based on MC56F8006, when I tried to initialize unused I/O pins by the bean inspector. After initialize the unused pins as output with internal Pullup resistor, I programmed once and when I tried to run, the CCS returned me a connectivity error. I tried one more time to program and the CCS returned the following error message: "the device is not powered up", but it really was, and the program, loaded once, was running correctly.

 

My MC56F8006 is working, but I can't load the program anymore.. Or since I've initialized the unused pins as output with pullup resistor.

 

I've made this test with 2 prototype boards (handmade), loading the program with a parallel JTAG connection and the USB-TAP... The same error has occurred.. I hope find a way to load my FWs again.. Somebody help me please!

 

Regards,

 

Janio

Outcomes