AnsweredAssumed Answered

No Freemaster connection with S32K148EVB-Q176

Question asked by Lawrence Minnetian on Dec 12, 2019
Latest reply on Dec 20, 2019 by Iulian Stan

Hi All,

 

I'm quite new to this all and tried to get my board up and running using a couple of different quick start guides and posts from this community. Unfortunately none of it has resolved my problem to connect in freemaster with the board described above.

 

I tried the following things:

 

- Installed FreeMaster v2 & v3

- Installed FreeMaster Communication Driver

- Installed Windows USB drivers from this website (PEmicro | Experts in Embedded tools for Flash Programming and Development )

- Updated MSD-Debug to v122 and OpenSDA to v108 using the bootloader mode on the target board

 

The way I'm trying right now is through the model based design toolbox by compiling simulink example models. I was able to flash a slightly modified LED example for the S32K148 board (I don't have stateflow) and added a Freemaster config block (attached images). When I open the board as a drive on my pc a .mot file shows up.

 

 

But when I run the connection wizard on FreeMaster it doesn't find the board. I have tried to follow some of the other guides, but had so far no luck. I followed this instructions as well S32K144 board detection problem , but I was not sure if it didn't work because I did something wrong or the difference in board won't make it work.

 

Either way, I'm somewhat out of ideas. Is it possible that one of the drivers wasn't installed properly? Is there a way to check?

 

Thanks for your help,

Lawrence

Outcomes