AnsweredAssumed Answered

LS1012ARDB-PC K22 CMSIS DAP USB bootloader bricked

Question asked by Christophe SCHMID on Nov 28, 2019
Latest reply on Dec 10, 2019 by Christophe SCHMID

Good morning all,

 

I specifically write to ufedor on NXP Kinetis support engineer suggestion.

I opened a ticket already: "Case:00242755:We bought a LS1012ARDB board and I bricked to OpenSDA firmware/bootloader on the K22 M"

 

Situation: we bought 2 brand new LS1012ARDB-PC boards and connected them to WIN10 hosts (ver 1909 so recent).

Problem: both RDBs got their K22 based CMSIS DAP bootloader bricked after having worked for a few days like a charm with CodeWarrior IDE.

 

I now try since ~1 week to reflash a new bootloader into the K22 of this QorIQ platform.

Of course I first and naturally started with the Kinetis folks who provide binaries here

OpenSDA Serial and Debug Adapter | NXP 

But this showed being the wrong path - QorIQ team also has it's own bootloaders and OpenSDA firmware running on also the K2x Kinetis familly. It's true: Kinetis MCUs and related bootloader are close and very similar - but that does not work this way as we all know, I was aware about this but was looking for some clear answer.

 

I also managed to get full DAPLink sources to rebuild my bootloader from scratch and flashing it using our MDK Pro IDE latest version + UlinkPro probes: DAPLink/DEVELOPERS-GUIDE.md at master · ARMmbed/DAPLink · GitHub 

 

Both approaches described above give same result: either K22 does not boot correctly or boots but USB device is not recognized by my WIN10 host. Remind: my goal is to first get BOOTLOADER MSC back so I can then simply drop into it the new DAPLink application binary - so far my bootloader remains silent. I am now convinced I use both wrong binaries and / or sources - I must get those not from Kinetis folks but from QorIQ folks here, agree.

 

So I was given from Kinetis support those links:

https://community.nxp.com/thread/483925?commentID=1054604#comment-1054604 

https://community.nxp.com/message/974928

 

Of course I read those posts and also directly tried the k22fx512_if_mbed.bin.zip that was provided by ufedor.

This comes as a BIN I first had to transform into a HEX so my MDK Pro + UlinkPro setup is able to flash it into the K22 target using latest srec_cat tool:

 

srec_cat.exe k22fx512_if_mbed.bin -binary -o k22fx512_if_mbed.hex -intel

 

My KEIL uVision project has correct packages and all is configured well, flash process terminates without error (checked the logs too). Confirm my K22 MCU is exactly this one: MK22FX512AVLH12

 

So here I am, what do I wrong? Is there a more recent binary I could get from QorIQ team that will not brick when connecting to WIN10 host? Our company only uses WIN10, I cannot change that. May sources so I rebuild the bootloader and OpenSDA or DAPLink on top as well? I saw on this link DAPLink/DEVELOPERS-GUIDE.md at master · ARMmbed/DAPLink · GitHub  that the projects.yaml file does not cover the very MCU used here but only k20dx_frdmk22f_if.

 

Thanks for helping. If we succeed in this I can give a go here to use this platform for an upcoming project. If not I may look for other alternatives, we cannot use bricked boards for development of course. Just saying that so you understand my reality and decision making I've to perform based on support feedback and help I get.

 

Thanks much & regards,

Christophe

Outcomes