AnsweredAssumed Answered

Pairing failed with Mode1 Level4 security in KW36

Question asked by Naven Suresh on Jun 29, 2019
Latest reply on Jul 4, 2019 by Naven Suresh

Pairing failed with Mode 1 Level 4 security in KW36

 

I changed the security mode to LE SC pairing by changing the parameters securityModeLevel, securityModeAndLevel to Mode 1 Level 4 in app_config.c file,

Also, I changed the “leSecureConnectionSupported” as “True” in gPairingParameters in app_config.c file.

 

After loading this wireless uart software into the target, I tried the following sequence:

 

Sequence:

 

  • Put the NXP LE in advertising mode
  • Initiate a connection from NXP IOT toolbox

 

Expected Behaviour:

 

  • The phone should get connected and we shall be able to send data over the air

 

Actual Behaviour:

 

  • Phone App shows the device as connected and when I tried transferring uart data, the data was not sent to NXP LE.

 

Took the sniffing log and understood that the “Pairing failed”(PFA) was sent by the NXP LE for the “pairing request”(Reason: Authentication Requirements) initiated by connected phone.

The issue is reproducible always.

One more point I would like to add, I changed the localIoCapabilities in pairing parameters to “gIoDisplayOnly_c”, that time the “passkey request”  method was used in the initiator side, at that time I didn’t face any problem,

In short with LE SC pairing and when it uses “Numeric Comparison” method, the pairing gets failed with reason Authentication Requirements.

 

 

Regards,

Naven Suresh

Outcomes